[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

cannot access encrypted USB drive with Thunar in Whonix 15

I posted this issue on http://forums.dds6qkxpwdeubwucdiaord2xgbbeyds25rbsgr73tbfpqpt4a6vjwsyd.onion/t/whonix-virtualbox-15-0-0-4-9-point-release/8076 but this thread is probably the right place for this.

Assuming it is permissions, I tried to run

Thunar

from the command line and got the same results as expected. Then, I tried

lxsudo Thunar

but that doesn’t show the USB drive.

And installing cryptsetup by default fixes this issue?

cryptsetup should be already installed by default?

Installing cryptsetup (manually) fixed the original issue in Whonix 14.

In Whonix 15, cryptsetup is already installed by default, but it doesn’t help. This time it seems like another problem though - there are no error messages at all, but nothing happens after entering the passphrase.

Would it help to start thunar from command line to see any error messages?

Does this also happen in Debian buster?

https://github.com/Whonix/security-misc/blob/master/etc/skel/.config/xfce4/xfconf/xfce-perchannel-xml/thunar.xml disables thunar-volman by default for better security.

Thunar -> edit -> preferences -> advanced -> enable volume management

Thunar -> edit -> preferences -> advanced -> configure -> check the removeable storage options

I still don’t see any error messages even when stating it from the command line.

Did you try that?

Yes, I tried it. I don’t see any change.
BTW - accessing an unencrypted USB drive works with or without those settings.

I managed to get an error message now (as a popup window) when instead of double clicking on the device, I right click and choose “Mount”. The follow error is generated:

Error unlocking /dev/sdb1: The function ‘bd_cryto_luks_open_blob’ called, but not implemented.

It appears at any case, with or without the volume management / removeable storage options.

Searching for this error, I got

http://www.askmeaboutlinux.com/?p=3444

$ sudo apt install libblockdev-crypto2
$ systemctl restart udisks2.service

I tried it, and now the USB volume doesn’t appear in thunar at all (good thing I saved a snapshot before I did it :slight_smile: )

Thunar issues could be related to root / sudo / pkexec.

See this thread / try this workaround:

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]