Whonix on Mac M1 (ARM) - User Support (still unsupported at time of writing)

Outdated git tag.

Can I download ready .utm whonix files for M1 MacBook, without building?

No. If that changes, these will be easily found on the website.

Thank you, seem i have missed a bit while i was away. Tried to build the project under build number as the new build documentation require. But got into some problems. I thought Tor browser would work now.


This is the build log trying to build it without using --tb open
But it did not work and got some errors. I did another build with --tb open and when i tried to start up Tor browser it was not installed. While trying to install it through the finished build it fails to download. Even when i try on CLI to use the command update-torbrowser it will fail to download.

So do we still need to manually download and install torbrowser? or have i done something wrong?

Thank you for your time, been away from this for a while so need to kinda get into this again.

ARM64 Tor Browser was signed with a new key.

gpg: keybox ‘/home/user/.cache/tb/gpgtmpdir/pubring.kbx’ created
gpg: /home/user/.cache/tb/gpgtmpdir/trustdb.gpg: trustdb created
gpg: key 6AF15D1E45FDCEC9: public key "Heikki Lindholm " imported
gpg: Total number processed: 1
gpg: imported: 1
gpg: Signature made Fri 10 Jun 2022 10:41:23 AM UTC
gpg: using EDDSA key 17646366EFF82DB13E5CCDB23A557859C963442B
gpg: Can’t check signature: No public key



That I don’t have that OpenPGP / gpg public key and neither can find it online.

ARM64 Tor Browser Maintainer

It must be possible to perform this manually before it can be automated in tb-updater.

I see, well update us when and if there is any changes to this.
Guess for now i need to do manual download for torbrowser like before.

  • Fixed tb-updater (with the new signing key) is now available in all Whonix repositories. Available after updating.
  • Additionally, optionally git tag has been created just now, which in theory should work but in practice is untested.

Tried to build both the gateway and the workstation with the git tag and the build failed right away when i tried to build it.


1 Like

I saw that a new update came out with the git tag and tried to build from that. But that failed as well. So i cannot build the project anymore on apple silicon based macs now. At least not on the newer tags.


1 Like

Yeah. That’s currently broken due to refactoring. This is the issue:

This forum thread has been moved just now to the newly created Unsupported Platforms - Whonix Forum category. The direct link to this forum post remains the same.

Moderation changes:

This forum thread was used as a mixed development discussion and user support discussion.

It will now become a user support only discussion.

This forum thread can still be used by users for asking questions, support (although there will probably no helpful answers as long as this is unmaintained), testing, expressing their interest and so forth.

To simplify potential future development discussion, a separate, development-only forum thread has been created just now:
Whonix on Mac M1 (ARM) - Development Discussion

This is a small change only. No worries. Future forum posts will be moved around accordingly should these end up in the wrong place.

As of the update with git tag there is some refactoring problems. As far as i understood this. Its means the script fails to build when certain part of the script should be run as user and other as root. Seems like the recommended part to do is to make the script run without sudo privileges. And when the script runs as root/sudo it will run that inside the script. Annoying part is that it will ask for pass everytime you get to a point where you should run as sudo. But could be easy solved by having a deb image only for building whonix so we can have sudo passwordless (well could be one way to solve it).

Anyways it seems like i cannot build anything unless a solution for this is solved. Also as i have understood it we will do all our talk about mac m1 on this forum post? what do we need to do to make mac m1 supported now? and how can i help moving forward on this project? apart from me finding bugs or problems when building.

1 Like

The current stable tag might be broken for arm64 builds because there’s no maintainer that before that tag was released kept testing Whonix builds and there’s currently no CI either that would have automatically reported the broken build.

If it’s just about Tor Browser download breaking the build, then --tb open or --tb none might fix it.

A maintainer basically needs constant brain cycles on the component, being diligent. For example, now it might make sense to add --tb none to the build parameter documentation but for the next stable tag when all of this is likely resolved, then there needs to be a reminder and action to remove that build parameter.

The refactoring issues will for sure be resolved in the next stable tag. Meanwhile, yeah, there’s a chance that builds are broken and unfixable by users. That’s what it means there’s no maintainer / unsupported.

No worries, it’s not going to be a huge usability mess. Password will only be required once and then cached using sudo’s existing mechanisms. Small documentation change. Not a big deal. Refactoring is progressing nicely.

As a non-developer you cannot.

It needs a maintainer, someone keeping brain cycles on the component, being diligent, contribution solutions, research, source code.

Thanks for asking. You could keep doing what you’re already doing.

When there’s a new testers-only or stable tag you could try another build.

Well stable git tag works with --tb open


Just need to manually download and install tor-browser on this one like before.
So when you can get version where i can build the project without the --tb open
Then i can test that out and build it again.

As of this moment i have just finished my bachelor degree as a computer engineer with security and networking as my specialty. That being said i am still pretty new to all of this and still searching for work. But i hope that one day i will get to a level where i can confidently help out on this project. I think its one of the better ways to surf the tor-web and is technically very interesting. I just need to really get into how the build script work, how everything is setup and be able to provide with you something useful. But for the moment i will try to build the project when newer tags comes inn. Also for those who ask explain to them how i build it.


Oh damn I’ve been trying to make a build for awhile now for the mac M1 and couldn’t make it work, I would just get errors in the build. Would sharing the UTM file be possible?

Not trivial. Software fork + project name change + hosting elsewhere required as per Whonix ™ Binary Images Policy.