[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

keyboard-configuration debconf popup during apt-get dist-upgrade

With Whonix 15.0.0.4.9 once upgrading, package keyboard-configuration asks what keyboard layout to use. Useless question for users already using the keyboard. More useless for GUI users. Usability issue. Upgrade non-interactivity issue.

Possibly (this) upstream bug but not worth reporting due to project inactivity.

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=840351

A potential workaround might be to preseed these debconf questions.

sudo apt-get install debconf-utils

sudo debconf-set-selections < keyboard-configuration.conf

keyboard-configuration.conf:

keyboard-configuration	keyboard-configuration/altgr	select	The default for the keyboard layout
keyboard-configuration	keyboard-configuration/compose	select	No compose key
keyboard-configuration	keyboard-configuration/ctrl_alt_bksp	boolean	false
keyboard-configuration	keyboard-configuration/unsupported_config_options	boolean	true
keyboard-configuration	keyboard-configuration/model	select	Generic 105-key PC (intl.)
keyboard-configuration	keyboard-configuration/switch	select	No temporary switch
keyboard-configuration	keyboard-configuration/unsupported_options	boolean	true
keyboard-configuration	keyboard-configuration/layoutcode	string	us
keyboard-configuration	keyboard-configuration/toggle	select	No toggling
keyboard-configuration	keyboard-configuration/variant	select	English (US)
keyboard-configuration	keyboard-configuration/store_defaults_in_debconf_db	boolean	false
keyboard-configuration	keyboard-configuration/optionscode	string	
keyboard-configuration	keyboard-configuration/xkb-keymap	select	us
keyboard-configuration	keyboard-configuration/unsupported_layout	boolean	true
keyboard-configuration	keyboard-configuration/layout	select	
keyboard-configuration	keyboard-configuration/unsupported_config_layout	boolean	true
keyboard-configuration	keyboard-configuration/modelcode	string	pc105

This could be added here:

https://github.com/Whonix/whonix-legacy/blob/master/debian/whonix-legacy.preinst

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]