[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Qubes 4.0-rc4 error in Tor Browser Downloader

So I just got Qubes 4.0-rc4 installed on my Librem 13v2, and updated && upgraded all of the things (including both whonix-ws and whonix-gw), but there is no Tor Browser on my system at all. So I run the Tor Browser Downloader on my whonix-ws TemplateVM (so I can destroy and spin up fresh anon-whonix AppVMs easily), but I continually get an error.

Error: Failed to download: https://www.torproject.org/projects/torbrowser/RecommendedTBBVersions.

It does the whole possible reasons thing which anyone who’s had issues should know, but at the bottom is this Debugging info:

Debugging information: curl_status_message: [35] - [SSL connect error. The SSL handshaking failed.]

I’ve done a lot of googling on these forums and elsewhere, and am finding different errors than my own, so I’d appreciate any help anyone can offer.

More info:

  • WhonixRepository has been run and active
  • WhonixCheck runs but does not show a Tor version (obviously because it’s not installed)
  • Ran update, upgrade, and dist-upgrade on both whonix template VMs (gw and ws) several times

Thanks anyone who can help. Super excited to get this up and going, and to contribute to the community once I get on my feet.

Hi Diego

Welcome to the community!

Sorry you’re having trouble. Have you looked at:

I’ve indeed manually installed the Tor browser in the meantime, but I’m wondering why it is that I have this issue to begin with, and if anyone else is having this issue. Can it be solved?

Hi rehrar

I can confirm having the same issue in Qubes 4.0-rc4 for the past 2 days. As the error message states the likely reasons are:

  • The download server is down.
  • File size exceeded (endless data attack triggered).
  • Tor Browser Downloader (by Whonix developers) has been broken due to upstream changes.

Recommendations: (as per error message)

This happens sometimes. You reported the issue so I don’t think this will be a problem for long and it may even resolve itself. It may be something simple but I don’t know.

This may be because not able to reach Tor Project.

https://forums.whonix.org/t/error-whonixcheck/4757

https://forums.whonix.org/t/transport-test-result-tors-transport-was-not-reachable-curl-return-code-35-ssl-connect-err/116

Please use thread Failure to download Tor Browser (SSL fail) instead.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]