kdesudo error popup window ( sdwdate-gui )

in multiple test instances in virtualbox, either the gateway or the workstation begin to regularly return the following error in a popup window on boot:

“No command arguments supplied!
Usage: kdesudo [-u ]
KdeSudo will now exit…”

i have not been able to determine what causes this regularly. is anyone else having similar issues? i’ve seen this mentioned in one other thread. but, i’m not sure if it is related.

Edit by Patrick to add screenshot:


Mysterious. Please kindly help to debug this.

  1. This might be fixed in proposed-updates / testers repository.
  2. If not…

Create log.

touch /home/user/kdesudo.log
chmod o+r /home/user/kdesudo.log
chmod g+r /home/user/kdesudo.log

Move the real kdesudo elsewhere.

sudo mv /usr/bin/kdesudo /usr/bin/kdesudo-real

Create the wrapper.

kdesudo kwrite /usr/bin/kdesudo


echo "$(whoami) $@" > /home/user/kdesudo.log
kdesudo-real "$@"


Me too, it throws the same error when booting up. In both the Gateway as in Workstation.

“No command arguments supplied! Usage: kdesudo [-u ] KdeSudo will now exit…”.

@tempest, @Patrick

It was fine couple days ago. Is it a security risk? And how to fix it?
I am using the latest Whonix from the site.

I would like to help, but “kdesudo kwrite /usr/bin/kdesudo” wont work. It gives me “could not find the database of available applications, run update-command-not-found as root to this” and “kdesudo: command not found”


when popup shown

ps axu | grep kdesudo

user 1154 0.0 0.4 330908 32988 ? Sl 21:27 0:00 kdesudo -session <long id>

That doesn’t give me any clues. kdesudo error popup window ( sdwdate-gui ) - #2 by Patrick required.

Please create a separate forum thread for that.

@Patrick. here is the output of kdesudo.log after error on boot:

user -u sdwdate-gui /usr/lib/sdwdate-gui/sdwdate-gui

1 Like

Ok thanks I will.
I hope we can fix this popup. Its annoying and maybe a security breach.

Frequently Asked Questions - Whonix ™ FAQ

That moves us a lot closer! Thanks!

Does your file /etc/sudoers.d/sdwdate-gui look like sdwdate-gui/sdwdate-gui at master · Kicksecure/sdwdate-gui · GitHub?

sudo cat /etc/sudoers.d/sdwdate-gui

What happens if you manually run…?


What happens if you manually run…?


What happens if you manually run…?

kdesudo -u sdwdate-gui /usr/lib/sdwdate-gui/sdwdate-gui

“System Settings” > “Startup and Shutdown” > “Desktop Session” > “Start with empty Session”

Will solve the issue

1 Like

works for me

Did sdwdate-gui autostart for you before doing “System Settings” > “Startup and Shutdown” > “Desktop Session” > “Start with empty Session”? I guess not.

And after “System Settings” > “Startup and Shutdown” > “Desktop Session” > “Start with empty Session” sdwdate-gui autostarts for you?

I can’t reproduce this.

We should still find out what “System Settings” > “Startup and Shutdown” > “Desktop Session” > “Start with empty Session” has to do with it anyway.

^ in worst case this does nothing. In best case it prevents the popup but sdwdate-gui still doesn’t autostart. Might also help us to debug this issue.

Thanks for the solving this. But it still bother me what the cause is? What are the consequences?


sdwdate-gui does not automatically start. Usability issue. More so once we implement ⚓ T551 enter Whonix firewall timesync-fail-closed mode before suspend / enter Whonix firewall full mode after resume and clock-fix.


an additional gui icon appears in the lower right corner. no error.

same as above. no error window.

also the same as above. no error.

1 Like

Could you try this version please?

@Patrick, the error still occurs with the above version.

1 Like

Not directly related, but…
Testing sdwdate-gui[qubes] in VirtualBox.

The kdesudo popup does not seem to be caused by sdwdate-gui.

Could you try the following:
In /usr/lib/sdwdate-gui/start-maybe comment out the line containing only sdwdate-gui
Reboot Whonix-Gateway.

sdwdate-gui is not started but the popup is still showing.

I have installed the kdesudo wrapper. With the above setup, nothing is written in kdesudo.log. When we let sdwdate-gui start at boot, we have the expected user -u sdwdate-gui /usr/lib/...

The installation of the new sdwdate-gui basically crash everything. After rebooting, at least whonix-firewall and Tor do not start, dolphin stops working… but the popup is not showing. That is the point. Something weird must be happening before… what?

1 Like

Networking not coming up?
sudo ifconfig

Could be this one:

But works again after reboot?