[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

kdesudo error popup window ( sdwdate-gui )

sdwdate-gui
bug
kdesudo

#23

i tried it. error still occurs and sdwdate still appears to be running per “sudo systemctl status sdwdate.service.”


#24

sdwdate is unaffected by all of this.

This is sdwdate-gui:


#25

right. my mistake. sdwdate-gui is not running. the error does still occur. kdesudo.log is empty.


#26

@patrick. others have run into the same problem. similar fix as mentioned above by @xXXXx. i guess kde is trying to “restore the previous desktop session.” setting it to a new session fixes the problem.

this fixed it for me as well. sdwdate-gui is running as well. so, in summary, here is the fix:

  1. go to “system settings -> startup and shutdown -> desktop session.”

  2. in the “on login” section, change it from “restore previous session” to “start with an empty session.”

a bit more on session management:
https://docs.kde.org/trunk5/en/kde-workspace/kcontrol/kcmsmserver/

i’d think that starting from an empty session, rather than saved application states at shutdown, is preferable for whonix anyways. or is there something i’m not considering? in whonix 13, the default option selected on install is “start with an empty session.”


Questions about Whonix Gateway
#27

This explain why my first whonix session (fresh from image) never gives me the popup screen. Its always on the follow bootup, its something to do with restoring previously sessions.


#28

disable KDE session restoration
https://phabricator.whonix.org/T822


Could someone please tell me which config is changed in which way when enabling/disabling KDE session restoration?

https://www.whonix.org/wiki/Dev/git#Put_folder_under_Git_Version_Control

That would help to disable it by default in next Whonix build.


#29

This seems to have fixed the kdesudo error.
I got the firewall error(on the gateway) after this procedure only one time(rebooting fixed it).

I will try to get the logs if it ever happens again.


#30

Here you go:

user@host:~$ git diff
diff --git a/.cache/icon-cache.kcache b/.cache/icon-cache.kcache
index 67b4173..75c3c0d 100644
Binary files a/.cache/icon-cache.kcache and b/.cache/icon-cache.kcache differ
diff --git a/.cache/plasma_theme_default_v5.25.kcache b/.cache/plasma_theme_default_v5.25.kcache
index 5cbbf00..635513a 100644
Binary files a/.cache/plasma_theme_default_v5.25.kcache and b/.cache/plasma_theme_default_v5.25.kcache differ
diff --git a/.config/ksmserverrc b/.config/ksmserverrc
index 6a25eea..f61c260 100644
--- a/.config/ksmserverrc
+++ b/.config/ksmserverrc
@@ -1,7 +1,7 @@
 [General]
 confirmLogout=true
 excludeApps=
-loginMode=restorePreviousLogout
+loginMode=default
 offerShutdown=true
 screenCount=1
 shutdownType=0
diff --git a/.local/share/kactivitymanagerd/resources/database-shm b/.local/share/kactivitymanagerd/resources/database-shm
index a52b824..a61564f 100644
Binary files a/.local/share/kactivitymanagerd/resources/database-shm and b/.local/share/kactivitymanagerd/resources/database-shm differ
diff --git a/.local/share/kactivitymanagerd/resources/database-wal b/.local/share/kactivitymanagerd/resources/database-wal
index 9e4f0a4..59c645b 100644
Binary files a/.local/share/kactivitymanagerd/resources/database-wal and b/.local/share/kactivitymanagerd/resources/database-wal differ
diff --git a/.xsession-errors b/.xsession-errors
index cb75eeb..1f96352 100644
--- a/.xsession-errors
+++ b/.xsession-errors
@@ -1973,3 +1973,5 @@ QDBusConnection: session D-Bus connection created before QCoreApplication. Appli
 QXcbConnection: XCB error: 3 (BadWindow), sequence: 1200, resource id: 67108865, major code: 18 (ChangeProperty), minor code: 0
 QXcbConnection: XCB error: 3 (BadWindow), sequence: 1329, resource id: 12582944, major code: 18 (ChangeProperty), minor code: 0
 kdeinit5: PID 1543 terminated.
+QXcbConnection: XCB error: 3 (BadWindow), sequence: 4697, resource id: 69206141, major code: 18 (ChangeProperty), minor code: 0
+QXcbConnection: XCB error: 3 (BadWindow), sequence: 4711, resource id: 37748873, major code: 18 (ChangeProperty), minor code: 0
user@host:~$

#31

This should be fixed by default in the next build.


#32

Damn i just discovered that i have reported this before almost one year:

https://phabricator.whonix.org/T737


#33

Hi guys,

In Whonix 14 Workstation XFCE (latest OVA), I’m still getting the kdesudo startup popup even with ksmserverrc set with loginMode=default.

It happened after installing a lot of programs, and I’m trying to troubleshoot the culprit by uninstalling KDE-related packages (like the useful partitionmanager that I installed), and doing a process of elimination.

But I’m suspecting it’s a legacy whonix package that’s still causing it. Any thoughts on this? Have the whonix ‘anon’ packages not been fully de-KDE’ified?


#34

Anonymous User:

But I’m suspecting it’s a legacy whonix package that’s still causing it. Any thoughts on this? Have the whonix ‘anon’ packages not been fully de-KDE’ified?

No code that I know could cause this. Can only be session management by
the desktop environment.


#35

Ok I’ve found the culprit: I had set a keyboard shortcut to run xfce4-session-logout --halt as as soon as that’s run (even once), I get a permanent kdesudo error in my Whonix over every reboot. Any idea how to fix it? It seems an XFCE bug. Perhaps a way to prevent whonix users from stuffing it up as well?

Edit: oh I solved it: in XFCE’s Session and Startup config, go to Session tab and click ‘Clear saved sessions’. That finally makes shut down super fast again! Hope that helps all of us to document that.