Disk & USB Automount in Kicksecure

For anyone who reads this and has the issue I had, I will summarize what I think fixed it.

Enable thunar-volman

In terminal: sudo nano /etc/skel/.config/xfce4/xfconf/xfce-perchannel-xml/thunar.xml

Line 15 <property name"misc-volume-management" type=“bool” value=“false”/>

Change from false to true

If still doesnt work try other things in the thread or:

Now we need to figure out which steps are required indeed and then document this.

Editing /etc/skel does nothing for existing user user. File edits are probably not required. GUI should suffice.

Alright, I will update this thread with better steps after I install kicksecure on another device and get this working from a fresh install again, and I try to narrow down the steps.

But I have to get everything I need working on that device before I install on other device, in particular the shared folders with vm, will make a thread about that now.


If encrypted disk, then this might help as per cannot access encrypted USB drive with Thunar in Whonix 15 - #9 by Patrick

sudo apt install libblockdev-crypto2
1 Like

Can we include this in Whonix since anyone who follows best practice would be encrypting their drives?

1 Like

This is done in git master as per cannot access encrypted USB drive with Thunar in Whonix 15 - #9 by Patrick

1 Like

Do we need


1 Like


1 Like

Like everything needs udev. It’s what populates /dev.

dmsetup is also likely needed by plenty of stuff.


This issue is considered fully resolved until someone reports again this being an issue.

  • We no longer enable hidepid by default.
  • We no longer change anything related to pkexec.
  • Missing packages are now installed by default.
  • User reported this being resolved.
  • Shared folder issue: if still an issue, please post in a separate thread.

(Since this was brought up here: Ledger Nano-S : No device found - #2 by HulaHoop)

1 Like