Ledger Nano-S : No device found

I hope this is the proper place to report such bugs, forgive me if not…

Whonix Version:
Affected component: (Non-Qubes) Whonix-Workstation XFCE (KVM/qcow2)
Steps to reproduce behavior:

  1. Apply udev rules as instructed,
  2. Pluggin in Ledger Nano-S on host (previously configured on a different guest),
  3. Enter PIN on device either before or after boot time or during virt-manager “Redirect USB Device”,
  4. Whonix-Worstation sees USB device,
  5. Apps like pre-installed Monero GUI or Ledger-Live Desktop do not find device.

Expected behavior: Guest system and apps find and use Nano-S

Actual behavior: Guest system sees device:

$sudo journalctl -f

Jan 01 21:31:54 host kernel: usb 1-1: USB disconnect, device number 2

Jan 01 23:12:10 host kernel: usb 1-1: new full-speed USB device number 3 using uhci_hcd
Jan 01 23:12:10 host kernel: usb 1-1: New USB device found, idVendor=2c97, idProduct=1011, bcdDevice= 2.01
Jan 01 23:12:10 host kernel: usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jan 01 23:12:10 host kernel: usb 1-1: Product: Nano S
Jan 01 23:12:10 host kernel: usb 1-1: Manufacturer: Ledger
Jan 01 23:12:10 host kernel: usb 1-1: SerialNumber: 0001
Jan 01 23:12:10 host kernel: hid-generic 0003:2C97:1011.0002: hiddev0,hidraw0: USB HID v1.11 Device [Ledger Nano S] on usb-0000:00:01.2-1/input0

But pre-installed Monero app or Ledger-Live Desktop cannot find or use Nano-S:

$monero-wallet-cli --version
Monero ‘Oxygen Orion’ (v0.17.1.7-release)

Monero-Gui 0.17.1-7-fed00a5 (Qt 5.15.2)
failed to generate new wallet: No device found

./ledger-live-desktop-2.19.0-linux-x86_64.AppImage --no-sandbox

Related info: Same Ledger Nano-S is found by apps on a different, vanilla, debian 10 guest on same host. Cannot change BIOS settings on KVM guest.

Happy to try and provide any other info to help troubleshoot.

1 Like

We are doing custom things to the mounting process which unfortunately makes this usecase not straight forward. Please try the steps in this thread to mount your device and let me know.

Ledger Nano S is a crypto currency hardware wallet. I don’t think it can be mounted in thunar. At least that wouldn’t be a common feature.

We didn’t as far as I know and anything related we don’t do anymore.

Disk & USB Automount in Kicksecure - #23 by 59mpci2GJ5xlHhY

Considered resolved. Closed issue just now:

1 Like

I believe that is true so I didn’t try that. I did look at all of the installed software, FYI, but did not see polkit-1-auth-agent (or anything that installs it) or xdg-user-dirs. I have not tried installing those yet.

I’ve also made sure software was up to date, that the Ledger firmware is up to date, and using the latest Ledger-Live -2.20 and latest Monero GUI still don’t “see” it.

Now, I also tried again on vanilla updated Debian 10 and Ledger Live 2.20 could see and manage it, but not Monero GUI. The only difference I can see is that xdg-user-dirs was installed (I didn’t see polkit-1-auth-agent installed either - but need to make sure nothing else is providing it.)

See also: