[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Wiki instructions on installing fresh whonix-gw/ws-16 breaks qubes-dom0-update

After I installed whonix-gw-16 following the instructions on the Whonix wiki (i.e. running sudo qubes-dom0-update first, then sudo qubes-dom0-update --enablerepo=qubes-templates-community qubes-template-whonix-gw-16 then setting sys-whonix to use whonix-gw-16). This is the error that I’m getting:

[user@dom0 ~]$ sudo qubes-dom0-update
Using sys-whonix as UpdateVM to download updates for Dom0; this may take some time...
Unable to detect release version (use '--releasever' to specify release version)
Last metadata expiration check: 0:00:21 ago on Thu Oct  7 20:15:56 2021.
Dependencies resolved.
Nothing to do.
Complete!
*** ERROR while receiving updates:
Error canonicalizing /var/tmp/qubes-updates-tmplhubwhkr.UNTRUSTED/qubes-template-whonix-ws-16-4.0.6-202109211111.noarch.rpm
--> if you want to use packages that were downloaded correctly, use dnf directly now

Hope someone can outline a solution as qubes-dom0-update is broken now for me and I can’t even install the whonix-ws-16 template or anything else.

Other people are reporting the same: forum qubes-os org/t/qubes-dom0-update-fails-to-detect-release-version-on-all-operations/6729

I followed the advise above to make a new qube and then use it as the default UpdateVM for dom0 and I was able to install whonix-ws-16 however after it gets installed I end up with the same problem

[user@dom0 ~]$ sudo qubes-dom0-update
Using new-updatevm as UpdateVM to download updates for Dom0; this may take some time...
Last metadata expiration check: 1:18:06 ago on Fri Oct  8 02:05:46 2021.
Dependencies resolved.
Nothing to do.
Complete!
*** ERROR while receiving updates:
Error canonicalizing /var/tmp/qubes-updates-tmp8yg9sb9s.UNTRUSTED/qubes-template-debian-11-4.0.6-202109010214.noarch.rpm
--> if you want to use packages that were downloaded correctly, use dnf directly now

Welcome to Whonix forums and thank you for the report!

Whonix doesn’t develop qubes-dom0-update. That’s Qubes. Therefore unfortunately I cannot help with it.

Qubes issue.

Qubes issue.

I.e. best probability of getting fixes for this issue is here:

Related:

Thanks Patrick for all of the work that you’re putting on Whonix!

Sorry if I wasn’t clear enough but the intent from my message was to say that the wiki article on updating should be updated, or at least contain a warning or a link to the discussed issue in the Qubes OS forums or on github. It seems most people are getting this issue when updating following the instructions on the wiki.

1 Like

There’s a notice for a few days now:

Issues
In case technical issues are experienced such as broken dom0, broken qubes-dom0-update are Qubes issues and unspecific to Whonix ™ and should therefore be either reported to qubes-issues [archive], or added as a comment to an existing issue there (if appropriate). This is further elaborated in What to post in this Qubes-Whonix forum and what not. [archive]

The instructions on this wiki page have bad usability. These are mostly out of control of the Whonix ™ project. See footnote for more information. [1]

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]