[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

VirtualBox Live VM Problems

Hey,

I tried to run Whonix in Live Mode on VirtualBox 6.1 on Win10 but it will either warn me that it can still write on the disk or crash immediately…

I can change the .vdi with VBoxManage to immutable but it will still get
Live mode is enabled but it is still possible to write to the disk.[…]
When I try to change it to readonly, VBoxManage will output
VBoxManage.exe: error: Cannot change type for medium ‘C:\Users\X\VirtualBox VMs\Whonix-Workstation-XFCE\Whonix-XFCE-15.0.1.9.3-disk002.vdi’ since it has 2 child media

VBoxManage setextradata Whonix-Workstation-XFCE “VBoxInternal/Devices/lsilogicsas/0/LUN#0/AttachedDriver/Config/ReadOnly” 1
will work but crash the VM on startup with details:
Failed to construct device ‘lsilogicsas’ instance #0 (VERR_PDM_CFG_MISSING_DRIVER_NAME).
E_FAIL (0x80004005)
IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Also updated and upgraded everything.

Windows 10 Pro Build 19043.1110
Whonix Build 15.0.1.9.3
VirtualBox Version: 6.1.22 r144080 (Qt5.6.2)

https://www.whonix.org/wiki/VirtualBox/Troubleshooting#Failed_to_open_a_session_for_the_virtual_machine?

Otherwise, try General VirtualBox Troubleshooting Steps.

Whonix doesn’t produce VirtualBox. Therefore if above doesn’t help:

I am trying to use Whonix in Live mode in VirtualBox. When I followed the pertinent VirtualBox instructions to set the drive read-only, it said to run this command:

VBoxManage setextradata Whonix-Workstation-XFCE “VBoxInternal/Devices/lsilogicsas/0/LUN#0/AttachedDriver/Config/ReadOnly” 1

I encountered this error when trying to start the virtual machine:

Failed to construct device ‘lsilogicsas’ instance #0 (VERR_PDM_CFG_MISSING_DRIVER_NAME).

Result Code:
NS_ERROR_FAILURE (0x80004005)
Component:
ConsoleWrap
Interface:
IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

There is another post in ‘Support’ (which I cannot link to) that details the same problem, and suggests changing the controller type to ACHI in the virtual machine settings. However this did not work.

Ubuntu 18.04
VirtualBox version: 6.1.22 r144080
Whonix version: 15.0.1.9.3

Try General VirtualBox Troubleshooting Steps .

Whonix doesn’t produce VirtualBox. Therefore if above doesn’t help:

This also occured to me when i was trying Whonix in Live Mode in Virtualbox I saw a warning saying, Whonix is in Live mode but it is still possible to write to disk please turn off the VM and set the disk to read only.I changed the disk to immutable but it was still showing the same warning.Then I tried to change the disk to read only in the host command prompt using the command

“VBoxManage setextradata Whonix-Workstation-XFCE “VBoxInternal/Devices/lsilogicsas/0/LUN#0/AttachedDriver/Config/ReadOnly” 1”
After that I opened the Vm in Virtualbox and It Showed

Failed to construct device ‘lsilogicsas’ instance #0 (VERR_PDM_CFG_MISSING_DRIVER_NAME).

Result Code: E_FAIL (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

I tried the above given fixes but it doesn’t work also changed the controller type to ACHII but it doesn’t work
Windows 11 Home Build 10.0.22000
Whonix Build 16.0.3.7
VirtualBox Version 6.1.30 r148432 (Qt5.6.2)

Same answer as above: VirtualBox Live VM Problems - #4 by Patrick

In this tutorial one of the step is missing:
Before executing the commands mentioned, you should set the type of the storage device controller from AHCI to LsiLogic SAS in the settings of the one/two virtual machine(s).

It is also able to stop the warning from being provoked by replacing lsilogicsas in the commands given with ahci, while the alert of the disk file being changeable will still exist, which indicates that this approach is not valid.

1 Like

You may refer to my answer below in this post.

You may refer to my answer below in this post.

Could you please [EDIT] (button in the wiki) the wiki?

Sure I will do it soon.

This only worked for gateway but for workstation it is showing

AHCI: Failed to attach drive to Port0 (VERR_PDM_CFG_MISSING_DRIVER_NAME).

Result Code: E_FAIL (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Did you apply this change for both gateway and workstation?

Also I am not sure it’s really optiomal to change back to lsilogicsas. In the past, Whonix deliberately moved from lsilogicsas to AHCI.

Quote Failed to open a session for the virtual machine

Failed to open a session for the virtual machine[edit]

If you see the following error message:

Failed to open a session for the virtual machine Whonix-Gateway-XFCE

If Result Code: NS_ERROR_FAILURE (0x80004005) is shown, then this chapter applies.

This occurs with all Whonix ™ VirtualBox versions up to version 15.0.1.7.2 when using VirtualBox version 6.1.20. VirtualBox version 6.1.20 solution:

  • VirtualBoxSettingsStorageType: AHCIOK [6]
  • Other settings remain unchanged.

This setting is the default in Whonix ™ version 15.0.1.7.3 and above (Point Release).

Note this setting might cause High Disk Usage Causing Filesystem Corruption on some (slower) hardware configurations due to a VirtualBox host software bug, High I/O causing filesystem corruption. This is speculation and unavoidable because there is no other solution at present. The High Disk Usage Causing Filesystem Corruption chapter has approaches which might fix this issue if it manifests.

To avoid issues like Failed to open a session for the virtual machine in the future, use the the recommended version of the VirtualBox host software and Stay Tuned.

Forum discussion: Whonix ™ VirtualBox - failed to start - NS_ERROR_FAILURE (0x80004005) - The VM session was aborted.

VirtualBox upstream bug report: VM Machine wont to start after upgrade to 6.1.20

Chapter https://www.whonix.org/wiki/VM_Live_Mode/ro-mode-init#Read-only_disk_on_VirtualBox is probably still from the time when Whonix was using lsilogicsas by default.

The real solution would be figuring out how to set read-only mode for VirtualBox harddrives with AHCI disk controller.

In other words…

lsilogicsas version:

VBoxManage setextradata vmname "VBoxInternal/Devices/lsilogicsas/0/LUN#0/AttachedDriver/Config/ReadOnly" 1

AHCI version:

?

1 Like

So is the AHCI Version

VBoxManage setextradata vmname “VBoxInternal/Devices/ahci/0/LUN#0/AttachedDriver/Config/ReadOnly” 1

1 Like

This warning still remains
image

Yes I did try it before, which indeed led to a successful start-up of the virtual machine, while the alert in Whonix, which says that the disk can still be written, still turned out to remain. I did not test whether the disk was actually able to be written and it might then be fault of check mechanism of disk properties run by Whonix. I reckon that the developers should go through that part of the code.

The Disk is not writable anymore thanks for the help

Then y’all guys may check the code related to mechanism of indication of writability of the disk

Great!

Is this tested?

Check https://www.kicksecure.com/wiki/VM_Live_Mode#Technical_Details.
(As per https://www.whonix.org/wiki/Free_Support_Principle.)

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]