[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

[VirtualBox] gateway & workstation freezing during inactivity


#1

I’m using Whonix since 8th version, and I’ve never encountered such problem.
When I work on workstation, after couple minutes, my connection is blocked because gateway is freezing itself.
Same thing is happening with workstation. When I’m living the computer, after 5 minutes screen saver on the host start working, and when I want to come back to Whonix, both gateway and workstation are blocked.

This is the prompt I get in gateway after freeze:

[ 940.101714] Freezing user space processes … (elapsed 0.004 seconds) done.
[ 940.107747] Freezing remaining freezable tasks … (elapsed 0.001 secodnds) done.
[ 940.110516] Suspending console(s) (use no_console_suspend to debug)

How can I turn it off?

E: Of course I’m talking about Whonix 11.


#2

It’s not a wanted feature. It’s either a bug in Whonix, the virtualizer or the host operating system. Therefore there is no obvious way to disable it. Best that can be done is asking questions back and forth. Hoping that way the cause can be debugged. So a workaround can be suggested as quick fix and so the bug might be fixed with an update.

Which virtualizer?

Which host operating system?

X, the graphical environment crashes and you’re left in the text console?

If you use your computer actively without inactivity, then Whonix-Gateway works fine for an unlimited amount of time?

Did you try to disable the screen saver on the host if it still happens then during inactivity? (I am not suggesting this as a permanent solution. For debugging only.)

Would be worth keeping a process monitor running. And “iotop -a”. Eventually monitoring things from tty0. Also check syslog. Do you know about this stuff?


#3
Which virtualizer?"
VirtualBox 4.3.30 r101610
Which host operating system?
Debian 8.1.0 x64
X, the graphical environment crashes and you're left in the text console?
No, console is not working. It's just a black screen and a prompt that I posted earlier. I need to power off virtual machine to end this error and move on.
If you use your computer actively without inactivity, then Whonix-Gateway works fine for an unlimited amount of time?
No, I need to do something on gateway every ten minutes, to keep it alive. No matter where I'm working (host or workstation).
Did you try to disable the screen saver on the host if it still happens then during inactivity? (I am not suggesting this as a permanent solution. For debugging only.)
Like I said, It freezes even when I working on the host. Just now gateway freeze. With the same prompt as earlier.
Would be worth keeping a process monitor running. And "iotop -a". Eventually monitoring things from tty0. Also check syslog. Do you know about this stuff?
No, please give me some details.

#4

As long as the desktop is running, you can start…

Then sort by CPU usage. Or memory. Keep looking what uses most or non-ordinary high amounts by comparison.

Also…

Install some tools.

Go to a virtual (text) console. (https://www.whonix.org/wiki/Desktop#Virtual_Consoles)

VirtualBox host key + F1 or F2, F3 etc
(right control is default)

Keep looking. See if any processes use and ridiculous amount >= 50% or more.

Also, keep watching syslog.

If it shows anything interesting. Or post the syslog here.


#5

I’m Having the same problem with Gateway freezing with suspended console showing up. Its happens after about 10min of using the virtualbox updated to the latest whonix version and only started happening since update?

I have to go to machine > shutdown to exit the error which then brings desktop back and re-establishes connection and ides?


#6

[quote=“whonixnoob, post:5, topic:1336”]I’m Having the same problem with Gateway freezing with suspended console showing up. Its happens after about 10min of using the virtualbox updated to the latest whonix version and only started happening since update?

I have to go to machine > shutdown to exit the error which then brings desktop back and re-establishes connection and ides?[/quote]
Please provide the debug output requested here:
https://www.whonix.org/forum/index.php/topic,1557.msg9704.html#msg9704


Bug
#7

I get this the same as guy above, and have to shut done which then prompts me to input password once I do that it take me back to the console and connection re-establishes.

[ 792.360696] Freezing user space processes … (elapsed 0.001 seconds) done.
[ 792.362632] Freezing remaining freezable tasks … (elapsed 0.001 seconds) done.
[ 792.364518] Suspending console(s) (use no_console_suspend to debug)

I checked the CPU usage:
Plasma desktop takes the most memory with 48k then Mysqld = 20k, xorg = 17k, Tor = 13k. Total 248Mb of 753Mb being used.

Have no idea why its doing this.


#8

I have also got this error not sure if its to do with my issue.

Erro:timesync_post_error has been run with following error text:
########################################
##Error detected! Please report this bug!#

BASH_SOURCE: /usr/lib/sdwate/modules.d/sdwate

SDW_EXIT_ON_ERROR:1

SDW_MODE: daemon

SDWDATE_SUBSHELL_SCLOCKADJ_EXIT_CODE:

current_time: Tue Aug 25 14:40:05 UTC 2015

exit_code:1

error_cause:

swdate_error_handler signal err detected in line 619 with BASH_COMMAND: echo “$@”
############################################


#9

[quote=“whonixnoob, post:8, topic:1336”]I have also got this error not sure if its to do with my issue.

Erro:timesync_post_error has been run with following error text:
########################################
##Error detected! Please report this bug!#

BASH_SOURCE: /usr/lib/sdwate/modules.d/sdwate

SDW_EXIT_ON_ERROR:1

SDW_MODE: daemon

SDWDATE_SUBSHELL_SCLOCKADJ_EXIT_CODE:

current_time: Tue Aug 25 14:40:05 UTC 2015

exit_code:1

error_cause:

swdate_error_handler signal err detected in line 619 with BASH_COMMAND: echo “$@”
############################################[/quote]
Using Whonix AppArmor profiles? -> Whonix AppArmor issue then.


#10

[quote=“spearmint, post:1, topic:1336”]I’m using Whonix since 8th version, and I’ve never encountered such problem.
When I work on workstation, after couple minutes, my connection is blocked because gateway is freezing itself.
Same thing is happening with workstation. When I’m living the computer, after 5 minutes screen saver on the host start working, and when I want to come back to Whonix, both gateway and workstation are blocked.

This is the prompt I get in gateway after freeze:

[ 940.101714] Freezing user space processes … (elapsed 0.004 seconds) done.
[ 940.107747] Freezing remaining freezable tasks … (elapsed 0.001 secodnds) done.
[ 940.110516] Suspending console(s) (use no_console_suspend to debug)

How can I turn it off?

E: Of course I’m talking about Whonix 11.[/quote]

Power management options in system settings. Nothing is freezing; your session is attempting to suspend itself. Turn off Suspend Session and Screen Energy Saving in all tabs.


#11

Ok, I turned it off. Seems like it’s the right solution, because after 30 minutes everything is fine.
I will report at the end of the day. Thanks for help!


#12

Same problem, same solution. Thanks. 8)

[quote=“d_xero, post:10, topic:1336”][quote author=spearmint link=topic=1557.msg9650#msg9650 date=1440235596]
I’m using Whonix since 8th version, and I’ve never encountered such problem.
When I work on workstation, after couple minutes, my connection is blocked because gateway is freezing itself.
Same thing is happening with workstation. When I’m living the computer, after 5 minutes screen saver on the host start working, and when I want to come back to Whonix, both gateway and workstation are blocked.

This is the prompt I get in gateway after freeze:

[ 940.101714] Freezing user space processes … (elapsed 0.004 seconds) done.
[ 940.107747] Freezing remaining freezable tasks … (elapsed 0.001 secodnds) done.
[ 940.110516] Suspending console(s) (use no_console_suspend to debug)

How can I turn it off?

E: Of course I’m talking about Whonix 11.
[/quote]

Power management options in system settings. Nothing is freezing; your session is attempting to suspend itself. Turn off Suspend Session and Screen Energy Saving in all tabs.[/quote]


#13

Can someone please try if installing power-savings-disable-in-vms from the testers repository solves this also? Because that’s the fix planned for Whonix 12.


#14

Seems to happen with VirtualBox only. Moved to Whonix VirtualBox forum.


#15

post instructions please and i will test for you and report back

i have been encountering this problem


#16

https://www.whonix.org/forum/index.php/topic,1910.0.html

(You don’t have to apt-get dist-upgrade. “sudo apt-get install power-savings-disable-in-vms” after enabling the testers repository should be sufficient.)


#17

Hi Patrick,

I have reduced the RAM to 384 and now using the gateway in GUI-less mode. So far, it has been running for about an hour or so with no drama. I will let it run for a while longer just to test if it fails.

After I have finished testing this, I will go back into normal GUI mode and make the modifications you suggested and post back the results. So, give me 1-2 days before you hear back from me.

Thanks.


Whonix gateway freezing
#18

#19

Does this still happen with Whonix 12.0.0.3.2 RC ( https://www.whonix.org/blog/whonix-12-0-0-3-2-rc-testers )?