USB Keyboard not working in whonix 15 VMs

I am relatively new to Qubes and Whonix as a whole.

I am using an external keyboard with all the other VMs, mounting it through the sys-usb desktop applet. In all the other VMs the USB keyboard is working as expected.

In any Whonix VM (I tested it with the Disposable VM and the default anon-VM) they keyboard is not working, although the applet does not show any mounting error.

I searched on this forum and found a terminal command that may help: lsblk .

I tried running it before and after mounting the keyboard through the applet, and the result in the terminal is the same: I get no change in the list of thigs shown. To be fair, I don’t really understand what that list is showing, but I know there’s no difference in the before and after.

Another post on this forum advises to “assign the usb PCI devices to that DispVM for a direct connection.”

I have no idea what that is and how to do that. I tried to look around with those keywords, but to no avail.

Any help would be highly appreciated.


Qubes issue.

Not Whonix issue.
Qubes-Whonix isn’t different in this regard from a Debian based VM in Qubes. Qubes-Whonix has no special code that changes anything related to keyboard.

I haven’t seen anywhere that Qubes requires a USB keyboard to be connected to any specific VM. (Excluding USBVM.) Or keyboard support being VM specific.

There please contact Qubes support. See:

What to post in this Qubes-Whonix forum and what not.