[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Unable to connect the Gateway to Tor network

Hello Team

This is my first post and I’m a Whonix newbie, so please apologize me in advance for the lack of skills.

I have an issue similar to the one described here: Workstation network/internet connection issue

But in my case I’m dealing with KVM VMs.

During the installation/configuration steps everything worked as expected, but when I try to run the check I get:


Create a file /etc/systemcheck.d/50_user.conf and add:
systemcheck_skip_functions+=" check_journal "
[INFO] [systemcheck] check network interfaces Result: Ok.
[INFO] [systemcheck] Qubes Settings Test Result: Skipped, because Qubes not detected.
[INFO] [systemcheck] Check Kernel Messages Test Result: Found nothing remarkable, ok.
[INFO] [systemcheck] Whonix firewall systemd unit check Result: Ok.
[INFO] [systemcheck] Check Package Manager Running Result: None running, ok.
[INFO] [systemcheck] Tor Check Result: Not running on Whonix-Gateway, ok.
[INFO] [systemcheck] Tor Config Check Result: Tor config ok.
[INFO] [systemcheck] Tor Pid Check Result: Not running on Whonix-Gateway, ok.
[ERROR] [systemcheck] Tor SocksPort Reachability Test Result: Unreachable! Unexpected error! (curl exit code: 56 | curl status message: [56] - [Failure in receiving network data.])
[INFO] [systemcheck] Tor Connection Result:
- Connecting for 0 seconds.
- Tor Circuit: not established.

My Host only accesses internet when the openvpn tun0 device is up because of the following firewall rules

Status: active

To                         Action      From
--                         ------      ----
192.168.1.0/24             ALLOW       Anywhere

192.168.1.0/24             ALLOW OUT   Anywhere
VPNIPADDRESS1/udp     ALLOW OUT   Anywhere
Anywhere                   ALLOW OUT   Anywhere on tun0
VPNIPADDRESS2/udp    ALLOW OUT   Anywhere

Anyway I’ve tried to disable the VPN and the firewall and the problem persists

this is the ip -a output:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether xxxxxxxx brd ff:ff:ff:ff:ff:ff permaddr xxxxxxxxxxx
    inet 192.168.1.200/24 brd 192.168.1.255 scope global eth0
       valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether xxxxxxxxxxxxxx:bd brd ff:ff:ff:ff:ff:ff
4: virbr1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether xxxxxxxx brd ff:ff:ff:ff:ff:ff
    inet 10.0.2.2/24 brd 10.0.2.255 scope global virbr1
       valid_lft forever preferred_lft forever
5: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
    link/ether xxxxxx brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
       valid_lft forever preferred_lft forever
6: virbr2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether xxxxxxxxxxxxx brd ff:ff:ff:ff:ff:ff
7: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN group default qlen 500
    link/none 
    inet 10.8.8.17/24 scope global tun0
       valid_lft forever preferred_lft forever
8: vnet0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master virbr2 state UNKNOWN group default qlen 1000
    link/ether xxxxxxxxxxxx brd ff:ff:ff:ff:ff:ff
9: vnet1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master virbr1 state UNKNOWN group default qlen 1000
    link/ether xxxxxxxxxxxxxx brd ff:ff:ff:ff:ff:ff
10: vnet2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master virbr2 state UNKNOWN group default qlen 1000
    link/ether xxxxxxxxxxxxx brd ff:ff:ff:ff:ff:ff

Thanks in advance for your help

Regards

Dear Patrick

Thanks for your help. The issue was caused by the time gap

It’s working now

Regards
A

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]