[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Tor Browser Downloader by Whonix - ERROR: Could not find out latest Tor Browser version! Excessive version string length. (323 characters)

#1

Tor Browser Downloader by Whonix will currently show.

ERROR:
Could not find out latest Tor Browser version! Excessive version string length. (323 characters) Either check.torproject.org has been compromised or this is a Whonix bug.
Possible reasons:

This is a known bug. No indicator for a security concern. It has already been reported to Tor Project:

Broken redirect on https://www.torproject.org/projects/torbrowser/RecommendedTBBVersions

Meanwhile please refer to:

Applications doesn't work
#2

Advanced users meanwhile could look up the version number here: https://2019.www.torproject.org/projects/torbrowser/RecommendedTBBVersions (or from other sources).

It’s possible to manually set the version you like to download thereby circumventing above bug.

Example stable version at time of writing:

tbb_version=8.0.8 update-torbrowser

Example stable version at time of writing:

tbb_version=8.5a10 update-torbrowser
#3

This bug also arises when updating qubes-whonix workstation template, after installing the latest point release to fix the recent apt vulnerability. An older tor version is supplied by qubesctl, so I updated tor using the internal updater.

#4

Please forgive my ignorance, but I’m not sure where to perform these instructions.

For example, I applied Patrick’s advice–which seemed to work–in the whonix ws template vm, but then running the anon-whonix torbrowser browser, I found even after a restart that it kept dying on this error.

Where does one normally apply instructions such as these? (My first thought was “in the template vm,” because I thought the app vms don’t persist changes…)

#5

Sorry I just noticed this is a Whonix forum, not Qubes OS… derp

#6

Hi HapticBovine

If you are referring to manual Tor Browser download this is done in the AppVM.

No worries you are in the right place since this bug affects all platforms i.e. Qubes-Whonix, Non-Qubes-Whonix. There is also a Qubes-Whonix forum if you want to take a look:

https://forums.whonix.org/c/qubes-whonix

What to post in Qubes-Whonix forum:

https://forums.whonix.org/t/what-to-post-in-this-qubes-whonix-forum-and-what-not/2275

1 Like
#7

0brand,

That seems to have worked nicely. Thanks for the clarifications.

#8
#9