[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Safe operating system guide: Setting up Email issue

Hi…AGAIN!

Run into a problem setting up the email as per the guide, once i get to the enigmail part, when i try to create keys, and click on ‘create revocation certificate’, it doesn’t create it.

I spoke to someone who mentioned it may be due to the version, but im not sure. I tried to uninstall thunderbird using the purge command, but when i did so it seems to have buggered my workstation setup, as when i restarted, i was presented with a login screen for workstation? something ive never encountered before.

Also, i now seem to have some process running in virtualbox which greys out the main screen and i have to restart the entire computer.

I’ve now reinstalled the workstation, went through the guide again to make the changes within workstation and am about to begin the email process again, but im going to wait for some kind instructions. :slight_smile:

Hi phantastic4012

I’m not sure if you realize that A Beginner Friendly Comprehensive Guide to Installing and Using A Safer Anonymous Operating System https://anonguide.cyberguerrilla.org/ is not a part of the Whonix documentation. Someone reading your post may not know what you are referring to when you reference Safe operating system guide.

As far as configuring email, you may want to try using the Whonix email documentation first and see if you can get if working. If you are having problems creating a revocation certificate you may want to check out the enigmain documentation.

https://www.enigmail.net/documentation/

If you are still having problems, could you please give steps to reproduce and any error messages.

1 Like

Hey

Ah crap, im really sorry guys, i thought i was creating it in correct place, im really really sorry…

Basically, im going through the enigmail wizard of creating keys for email. Once these are created, the option comes up to create a revocation certificate, the keys get generated, but its followed by a pop up stating that the rev cert couldn’t be created.

I did however manage to create the rev cert through konsole, which i think should be ok, of course ive no idea what im doing so could be wrong lol

HI phantastic4012

No worries, I just wanted to make sure you were aware it wasn’t part of the whonix wiki.

Glad to here you were able to create your rev cert!

@phantastic4012, this is an issue with the apparmor profile that is now shipping with thunderbird. the quick and dirty fix is to delete the apparmor profile.

sudo rm /etc/apparmor.d/usr.bin.thunderbird /etc/apparmor.d/local/usr.bin.thunderbird

1 Like

@tempest

Thanks very much sir, that solved it a treat :slight_smile:

P.

hopefully, whatever is causing this will get fixed upstream in the future. going forward, when thunderbird is updated, you’ll likely get a notification about installing the new apparmor profile, where your default choice will be “n” for no. you can choose to install it and, if it breaks thunderbird again, simply repeat the command from my last post.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]