[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Qubes-Whonix upgrade not possible

Hello everyone.

Attention, as this is my first post on the forum, the system wanted me to delete all the links and all the images…

I just installed Qubes on my machine.

I launched the update manager (the little star on the top right). All the updates have been done, except for whonix-ws.

iiiii
iiiii

I read (too late) this article where it is specified that you should not use the “Qube manager” to update whonix…
LLLLL

So I tried in command line, by going in the applications

Model : whonix-gw-15 : terminal Xfce
Model : whonix-ws-15 : terminal Xfce

whonix-gw has been updated but not whonix ws :
iiiii

Qubes 4.0.4 contains Whonix 15 … but this page :
LLLLL
proves that you can install a stable version 16 of Whonix in Qubes 4.0.4.

I did the following test:
sudo cat /srv/formulas/base/virtual-machines-formula/qvm/whonix.jinja
…the terminal showed me version 15.

Then I tried another method: I opened the dom0 terminal and executed the following line:
sudo qubes-dom0-update --enablerepo=qubes-templates-community qubes-template-whonix-gw-16 qubes-template-whonix-ws-16

… as shown in this document :
LLLLL

It doesn’t work and the download restarts every time. As you can see in the screenshots below, this would be an expired certificate issue:
iiiii

iiiii

Currently, I really don’t know what to do…

I must specify that I am a beginner in learning under Linux…

Then I tried another method: I opened the dom0 terminal and executed the following line:
sudo qubes-dom0-update --enablerepo=qubes-templates-community qubes-template-whonix-gw-16 qubes-template-whonix-ws-16

It doesn’t work and the download restarts every time. As you can see in the screenshots below, this would be an expired certificate issue:

This is more of a Qubes issue, as they host the templates for download.
However, since it sounds like you are doing a new install, might want to
redo it with Qubes 4.1rc1 (Download Qubes OS | Qubes OS) since it
includes Whonix 16 GW & WS.

1 Like

Welcome to Whonix forums and thank you for your question!

You can post links now.

Root cause. You cannot proceed until this is fixed.
dom0 update required. This is mentioned in Qubes-Whonix installation documentation.
If dom0 update won’t update this file then that’s a Qubes, not a Whonix issue. → What to post in this Qubes-Whonix forum and what not.

qubes-dom0-update certificate issue → Qubes issue → What to post in this Qubes-Whonix forum and what not.

Note:

1 Like

I understand. Thank you for your answer.

I preferred to reinstall everything normally, because I will use Qubes for my work.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]