[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Package Conflicts?

user@host:~$ sudo apt list --upgradable -a && sudo apt update && sudo aptitude dist-upgrade 
Listing... Done
qubes-whonix-workstation/unknown,unknown 3:7.1-1 all [upgradable from: 3:6.9-1]
qubes-whonix-workstation/now 3:6.9-1 all [installed,upgradable to: 3:7.1-1]

Hit:1 http://security.debian.org stretch/updates InRelease                                                                                                                                                                                                                     
Hit:2 http://deb.torproject.org/torproject.org stretch InRelease                                                                                                                                                                                                               
Ign:3 tor+http://vwakviie2ienjx6t.onion/debian stretch InRelease                                                                                                                                                                                                               
Hit:4 tor+http://sgvtcaew4bxjd7ln.onion stretch/updates InRelease                                                                                                                                                                 
Hit:5 http://deb.qubes-os.org/r4.0/vm stretch InRelease                                                                                                                                                                                
Hit:6 tor+http://deb.sik5nlgfc5qylnnsr57qrbm64zbdx6t4lreyhpon3ychmxmiem7tioad.onion/r4.0/vm stretch InRelease                                                                                                                          
Hit:7 tor+http://deb.dds6qkxpwdeubwucdiaord2xgbbeyds25rbsgr73tbfpqpt4a6vjwsyd.onion stretch-testers InRelease                                                                                        
Hit:8 tor+http://vwakviie2ienjx6t.onion/debian stretch-backports InRelease                                                                                                
Hit:9 http://ppa.launchpad.net/nextcloud-devs/client/ubuntu artful InRelease                                                                           
Hit:10 http://deb.whonix.org stretch-testers InRelease                                                                                                 
Hit:11 tor+http://deb.sik5nlgfc5qylnnsr57qrbm64zbdx6t4lreyhpon3ychmxmiem7tioad.onion/r4.0/vm stretch-testing InRelease     
Hit:12 tor+http://vwakviie2ienjx6t.onion/debian stretch Release                                                            
Hit:14 tor+http://deb.sik5nlgfc5qylnnsr57qrbm64zbdx6t4lreyhpon3ychmxmiem7tioad.onion/r4.0/vm stretch-securitytesting InRelease
Ign:15 http://ftp.us.debian.org/debian stretch InRelease                 
Hit:16 https://updates.signal.org/desktop/apt xenial InRelease
Hit:17 http://ftp.us.debian.org/debian stretch Release
Reading package lists... Done
Building dependency tree       
Reading state information... Done
1 package can be upgraded. Run 'apt list --upgradable' to see it.
The following packages will be REMOVED:  
  qubes-core-agent-passwordless-root{u} qubes-whonix-shared-packages-recommended{u} 
The following packages will be upgraded:
  qubes-whonix-workstation{b} 
1 packages upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
Need to get 24.8 kB of archives. After unpacking 106 kB will be freed.
The following packages have unmet dependencies:
 qubes-whonix-workstation : Depends: qubes-whonix-shared-packages-recommended-cli which is a virtual package and is not provided by any available package

The following actions will resolve these dependencies:

	 Remove the following packages:            
1)     qubes-whonix-workstation [3:6.9-1 (now)]



Accept this solution? [Y/n/q/?]
1 Like

Wait for updates.


A post was split to a new topic: dist-upgrade to stretch-backports

Please tell me there is something that can be done to fix this catastrophe

https://www.whonix.org/wiki/Stay_Tuned#Whonix_Repository_Testers

Should be fixed in all repositories.

Users should always be able to install the latest packages from Fedora’s repos regardless of what other Fedora packages are installed. Therefore, whenever possible, the latest Fedora packages of a release should avoid conflicting with each other liteblue.

Qubes-Whonix doesn’t interact with Fedora packages.
This is a Qubes-Whonix support forum only.
This is not a general Qubes support forum. See:

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]