[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Missing dependencies on Buster for Virtualbox 6.1.6

Hello,
I am on Debian Buster and use VirtualBox from the repositories provided on the Whonix website. Today, my system upgraded to VirtualBox 6.1.6. The kernel modules built and installed:

root@buster:~# dkms status
virtualbox, 6.1.6, 4.19.0-9-amd64, x86_64: installed
virtualbox-guest, 6.1.6, 4.19.0-9-amd64, x86_64: installed

But it seems that the VirtualBox GUI has unresolved dependencies. Aptitude says thaty Python3 >= 3.8, libgcc-s1 >= 3.0 and many more are required that are only available on Debian testing.

Any help is greatly appreciated.

Best regards,

R.

Hello,
This seems to be a VirtualBox issue unrelated to Whonix.

But it seems that the VirtualBox GUI has unresolved dependencies. Aptitude says thaty Python3 >= 3.8, libgcc-s1 >= 3.0 and many more are required that are only available on Debian testing.

Meaning what, that you can’t launch VirtualBox or can’t upgrade it?

1 Like

Hello,

I am not sure if the missing dependencies are required to build Virtualbox 6.1.6. I posted it here because 6.1.6 is the version that the debian package manager now tries to install using the recently updated repositories that whonix explicitly provides for debian buster.

The dependencies in this repository should be fulfilled on a clean buster installation. Nevertheless, the GUI requires packages (or versions of packages) that are not available on buster, which means that they may have been built on debian testing, where they will probably install.

On my system (buster), the kernel modules of 6.1.6 were built during the installation and were loaded into the kernel. But the GUI does not upgrade from 6.1.4 to 6.1.6 due to the missing dependencies. (The GUI is not built during the installation.) I can run Virtualbox with the 6.1.4 GUI, though.

Best regards,
R.

It requires to build a backport. I am downloading virtualbox sources from Debian sid, build the backport Debian packages (deb's) for Debian buster ad then upload to Whonix repository.

Since the version difference (changelog) VirtualBox 6.1.6 vs VirtualBox 6.1.8 isn’t security relevant and also otherwise brings no changes that I find critical importance, it will take time to upgrade VirtualBox 6.1.6 to VirtualBox 6.1.8 in Whonix repository. Possibly an upgrade will be skipped entirely.

Meanwhile, if you want a newer VirtualBox version anyhow, you’re mostly on your own. This page has some hints:

Not a Whonix issue. The technical background / mess is documented here:
Installing VirtualBox on Debian 10 / Debian buster / buster-backports / fasttrack

https://www.whonix.org/wiki/Free_Support_Principle applies. Installing a newer version of VirtualBox is unspecific to Whonix. Same way that would work for Debian should also work for Whonix.

Whonix can’t fix all mess. Whonix isn’t Oracle Corporation (the company who bought VirtualBox). Quote wikipedia:

Revenue Increase US$39.50 billion (2019)[3]
Operating income Increase US$13.53 billion (2019)[3]
Net income Increase US$11.08 billion (2019)[3]
Total assets Decrease US$108.70 billion (2019)[3]
Total equity Decrease US$22.36 billion (2019)[3]
Number of employees 136,000 (2019)[4]

Looks pretty dire for now.

The following packages have unmet dependencies:|
libc6-dev : Breaks: libgcc-8-dev (< 8.4.0-2~) but 8.3.0-6 is to be installed

I’ve worked around 1 issue.

https://gitlab.com/whonix/Whonix/-/commit/8025c190e78ad1eeeb9a6e1eca5b908519832354

But now another issue similar to build failing on Debian buster at kmk_builtin_append out/obj/VBoxGlobal/qtrcc/VirtualBox2_x4.gen.cpp (which could be solved by not building inside Qubes but building on real Debian).

Now with VirtualBox 6.1.6 build failing even on Debian.

c/runtime/UISession.o.dep" “” “/home/user/whonix_binary/temp_packages_virtualbox/virtualbox-6.1.8-dfsg/src/VBox/Frontends/VirtualBox/src/runtime/UISession.cpp:” “”
kmk: *** Exiting with status 2

Hence asking for help:
https://twitter.com/Whonix/status/1268525273852661765

This doesn’t look good.

https://ircbots.debian.net/judd/#judd-builddep

(checkbackport [–fromrelease ] [–torelease ] [–arch ] [–verbose]) – Check that the build-dependencies listed by a package in the release specified as “fromrelease” are satisfiable for in “torelease” for the given host architecture. By default, a backport from unstable to the current stable release and amd64 are used.


checkbackport virtualbox

Backporting package virtualbox in sid→buster/amd64: unsatisfiable build dependencies: Build-Depends: debhelper-compat (= 12).


checkbackport virtualbox --verbose

Backporting package virtualbox in sid→buster/amd64: unsatisfiable build dependencies: Build-Depends: debhelper-compat (= 12).
buster: bzip2,default-jdk,jaxws,dh-python,dkms,docbook-xml,docbook-xsl,dpkg-dev (>= 1.15.6~),g+±multilib,genisoimage,gsoap,acpica-tools,imagemagick,kbuild (>= 1:0.1.9998svn3098~),libasound2-dev,libcap-dev,libcurl4-gnutls-dev,libdevmapper-dev,libdrm-dev,libegl1-mesa-dev,libgl1-mesa-dev,libglu1-mesa-dev,libgsoap-dev,libidl-dev,libopus-dev,libpam0g-dev,libpixman-1-dev,libpng-dev,libpulse-
dev,libqt5x11extras5-dev,libqt5opengl5-dev,qttools5-dev-tools,libsdl1.2-dev,libssl-dev,libvncserver-dev,libvpx-dev,libx11-dev,libxcomposite-dev,libxcursor-dev,libxdamage-dev,libxext-dev,libxi-dev,libxinerama-dev,libxml2-dev,libxml2-utils,libxmu-dev,libxrandr-dev,libxrender-dev,libxslt1-dev,libxt-dev,lsb-release,lynx,makeself,module-assistant,python3-dev,texlive-fonts-extra,texlive-fonts-recommended,texlive- (1 more message)

Because of this currently building Whonix VirtualBox from source code is also broken.

An awful, not great solution for future Whonix VirtualBox development might would be to install VirtualBox from Oracle Repository and then try make VirtualBox guest additions from ISO work and pre-install / automate that.

Related:

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]