KVM Debian Buster

Hello , am a new VM user on Debian Buster, long time Qubes whonix user.
following the KVM Whonix installation all goes well until
I attempt to start the -workstation I get 'cannot set CPU affinity on process 3972: Invalid argument.

I’m not an advanced user

Rebooting VMM and Buster, same error just different PID TIA

Hi. Please follow these instructions and try again:

If you are running KVM nested in Xen it may also be a cause of unforeseen problem. Maybe you don;t have nested virtualization enabled or the vtx instruction passed through. Anyway, let;s start with this above fix first.

ok I used nano and removed the cpuset=‘1’

-ws seems happy now,

thanks for your fast reply and awesome work !

btw: this is a Lenovo T- series laptop

1 Like

If you have high security requirements, I’d stay away from Chinese OEM laptops. Or plan accordingly if that’s not an option.