[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

kdesudo error popup window ( sdwdate-gui )

That doesn’t give me any clues. kdesudo error popup window required.

Please create a separate forum thread for that.

@Patrick. here is the output of kdesudo.log after error on boot:

user -u sdwdate-gui /usr/lib/sdwdate-gui/sdwdate-gui

1 Like

Ok thanks I will.
I hope we can fix this popup. Its annoying and maybe a security breach.

https://www.whonix.org/wiki/FAQ#Compromise_Indicators

That moves us a lot closer! Thanks!

Does your file /etc/sudoers.d/sdwdate-gui look like https://github.com/Whonix/sdwdate-gui/blob/master/etc/sudoers.d/sdwdate-gui?

sudo cat /etc/sudoers.d/sdwdate-gui

What happens if you manually run…?

sdwdate-gui

What happens if you manually run…?

/usr/lib/sdwdate-gui/start-maybe

What happens if you manually run…?

kdesudo -u sdwdate-gui /usr/lib/sdwdate-gui/sdwdate-gui

“System Settings” > “Startup and Shutdown” > “Desktop Session” > “Start with empty Session”

Will solve the issue

1 Like

works for me

Did sdwdate-gui autostart for you before doing “System Settings” > “Startup and Shutdown” > “Desktop Session” > “Start with empty Session”? I guess not.

And after “System Settings” > “Startup and Shutdown” > “Desktop Session” > “Start with empty Session” sdwdate-gui autostarts for you?

I can’t reproduce this.

We should still find out what “System Settings” > “Startup and Shutdown” > “Desktop Session” > “Start with empty Session” has to do with it anyway.

https://github.com/Whonix/sdwdate-gui/commit/4a4f91f273d4db29d76c1f8221238bf9d71a6115

^ in worst case this does nothing. In best case it prevents the popup but sdwdate-gui still doesn’t autostart. Might also help us to debug this issue.

Thanks for the solving this. But it still bother me what the cause is? What are the consequences?

Unknown.

sdwdate-gui does not automatically start. Usability issue. More so once we implement https://phabricator.whonix.org/T551.

yes.

an additional gui icon appears in the lower right corner. no error.

same as above. no error window.

also the same as above. no error.

1 Like

Could you try this version please?

@Patrick, the error still occurs with the above version.

1 Like

Not directly related, but…
Testing sdwdate-gui[qubes] in VirtualBox.

The kdesudo popup does not seem to be caused by sdwdate-gui.

@tempest
Could you try the following:
In /usr/lib/sdwdate-gui/start-maybe comment out the line containing only sdwdate-gui
Reboot Whonix-Gateway.

sdwdate-gui is not started but the popup is still showing.

@Patrick
I have installed the kdesudo wrapper. With the above setup, nothing is written in kdesudo.log. When we let sdwdate-gui start at boot, we have the expected user -u sdwdate-gui /usr/lib/...

The installation of the new sdwdate-gui basically crash everything. After rebooting, at least whonix-firewall and Tor do not start, dolphin stops working… but the popup is not showing. That is the point. Something weird must be happening before… what?

1 Like

Networking not coming up?
sudo ifconfig
?

Could be this one:

But works again after reboot?

i tried it. error still occurs and sdwdate still appears to be running per “sudo systemctl status sdwdate.service.”

1 Like

sdwdate is unaffected by all of this.

This is sdwdate-gui:

right. my mistake. sdwdate-gui is not running. the error does still occur. kdesudo.log is empty.

1 Like

@patrick. others have run into the same problem. similar fix as mentioned above by @xXXXx. i guess kde is trying to “restore the previous desktop session.” setting it to a new session fixes the problem.

this fixed it for me as well. sdwdate-gui is running as well. so, in summary, here is the fix:

  1. go to “system settings -> startup and shutdown -> desktop session.”

  2. in the “on login” section, change it from “restore previous session” to “start with an empty session.”

a bit more on session management:
https://docs.kde.org/trunk5/en/kde-workspace/kcontrol/kcmsmserver/

i’d think that starting from an empty session, rather than saved application states at shutdown, is preferable for whonix anyways. or is there something i’m not considering? in whonix 13, the default option selected on install is “start with an empty session.”

2 Likes

This explain why my first whonix session (fresh from image) never gives me the popup screen. Its always on the follow bootup, its something to do with restoring previously sessions.

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]