[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Installing Firefox in Whonix

Hi, Im trying to installation Firefox in whonix

I folow the instruktions on whonix org.

And run
sudo apt-get install firexfox-esr

Then I run the universal pasword changeme and what I presume is the download and installation starts.

However after some time its stops and this mesage comes up
Processing triggers for desktop-file-utils (0.23-4)

line under this comes up
user@host:$

I guse I sould type some comand again. but have no ider what to do at this point.

Would be grate if some one could give me so guidens on this! Thanks.

Hello,

You should learn how to use Linux and Debian before attempting to use Whonix.

This is expected. This is how most if not all Linux distributions work when using command line.

After installing you can start the program from the command line and in case of graphical applications such as Firefox also from start menu.

See https://www.whonix.org/wiki/Free_Support_Principle

Also Tor Browser should be preferred in most cases in Whonix. See:

Hi, I have to come back with some clarification and further questions.

I made an error and typed the comand abow in the gateway not the worksation.

I just presumed that was the way to do it.

Any way I noticed that it did install in the gateway. However objusly its no use having it there.

So I tried the same comand in workstation.

And get this mesage right away (ofter typing the pasword):
Unabel to locate package firefox-esr

Dose any one have the solution for this? It would be grate if some one could tell me how to fix this. Objusly the package whas found and instald when I did typing the same comand in gateway.

So what sould I do to download and install Firefox in workstation?

I have reason for whnating Firefox in whonix. I have further qustion on that as well. That I hope can be sorted out later. But thats an topic for an other thread I think. And Im trying to keep it fokused on this sigel issue for now.

Again if some one could give me som guidens I would be gratefull.

apologys for any gramtic faoult.

81a989, Hopofulle I will not encounter any more issues. Brozing and other taskes works fine whith this amazing software and thats my primary objectiv. I do read as mutch as I can tough. An will switch to Linux on host as well very sone.

No one knows?
As I sad it works in gateway hence I presume somethings wrong with my workstation.

This is some one related to my isue

I found an oterh topic at this Forum where some one got the same error while installing an other software. .

In this topic the say that the installer is looking for the file in the operating system not the internet. And hence he sould type

deb cdrom

I tried the same and some thing did hapen when I typed the orginal comand sudo app-get install Firefox-esr
To start with a numer of new lines aperas

and att the end I get this mesage:
Releas esr for firefox not found

I starting to wounder if ts the prefix

this comand
sudo apt-get install firefox-esr

did work after updating
sudo apt-get dist/upgrades

also typing
#deb cdrom
might have helpt.

If any one ells likes to do it.

By the way I made changes in the in the mozial brozer (about:config). Like in the guide.

And after tor and mozial (in whonix) showed identical value in panoptiklick.

Found it on on restoreprivacy under the topic:
firefox privacy and browser fingerprinting.

Also there are some intresting plugin for mozial one called chameleon. That can chnage the makeup of the brozer every minute if you wish.

Might be of intrest if some on would like to use mozial.

Whonix is based on Debian. Please learn about Debian. Asking Debian questions in Whonix forums is as you can see - inefficient. If you can imagine that what you’re trying to accomplish has been tried to accomplish before by other people - then it is probably so - therefore expect these questions having asked, answered, documented on the internet before. Asking them in a forum has a good chance of being ignored - since the answer is only away “1 google search”.

This is similar to what https://www.whonix.org/wiki/Free_Support_Principle is saying.

If links are provided - please read them.

Use Tor Browser. That is the browser with as many privacy settings applied by default.

See:

cdrom stuff would be using a physical (real world) CD-ROM. Probably not useful in context of Whonix for what you’re trying to do. There’s no cdrom lines in Whonix by default and adding any makes no sense either.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]