[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

inform user that torbrowser won't start

export tb_no_start="true"

prevents torbrowser from starting, but no info message is shown on the gui or on the cli, would need to enabled set -x at the top.

What I want to do is print on both as the default behavior.

I want some of my qubes to not start the browser, but in the future I can forget why the browser is not starting as no info message is printed.

Another thing, tb_no_start should be capitalized as it is an environment variable.

Just a console output or console output + popup?

For that, could you create a separate forum thread please? Variables naming conventions lower case versus uppercase… That would need to be resolved if there is a convention for this or one way being more popular than the other or some sort of authoritative bash style guide. Because there would be many variables in Whonix source code that would have to be renamed.

yes

1 Like

Now that I saw /etc/torbrowser.d, the variable can be set there, but will only persist on templates.

Which I think it is fine, but that is why I am exporting the variable via /rw/config/rc.local, because it is either that or appending to /etc/torbrowser.d/50_user.conf with rc.local again for per qube configuration.

Anyway, I just want it to inform why torbrowser won’t start.

1 Like

/usr/local/etc/torbrowser.d works for per app qube, just missing documentation.

Missing documentation:

  • about /usr/loca/etc/torbrowser.d
  • about all variables that can be set

to be added to the files:

Missing informative message

about why the browser won’t start, because some variable was set in this case for it to not start at all.

1 Like

Any idea for a better text?

tb_start_tor_browser() {
   if [ "$tb_no_start" = "true" ]; then
      true "INFO: not starting $tb_title because tb_no_start is set to true."
      local MSG="\
<p>Not starting $tb_title as variable \$tb_no_start set to \"true\"!<br></br>
<br></br>
More info: User configured tb_no_start=\"true\"</p>"

      $output ${output_opts[@]} --messagex --titlex "$TITLE" --typex "error" --message "$MSG" --done
      $output ${output_opts[@]} --messagecli --titlecli "$TITLE" --typecli "error" --message "$MSG" --done
      exit 0
   fi

....
}

maybe the exit code should be a different one, like 1, but it report as a bug if you run with torbrowser whonix.org because of the link confirmation handling.

1 Like

Pull request welcome.

Not sure about exit code. But I am OK with exit code 1. Because if tb-starter is configured to not start and then uses starts it anyhow, then maybe that should be considered user error and exit non-zero.

Ok, just trying to avoid someone filling a bug beause it reports to them that they should report a bug to whonix, even though I understand it is not a bug.

Will MR soon, just seeing if there is any other option to not start tor not reporting it explictly.

1 Like

2 posts were split to a new topic: /rw/config versus /usr/local/etc

1 Like

Excellent! Merged. Thank you!

(But reverted the /rw related changes as per /rw/config versus /usr/local/etc)

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]