[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Increase Default Workstation RAM to 2GB?


#1

As per version 14.0.0.9.6 Workstation default RAM is 1024 MB. In my experience it always becomes unusable after a few Tor Browser tabs are open, even with XFCE.

I know this was already addressed some 4 years ago:

But still, average computer power has increased since then, and 1GB of RAM for a Workstation is really limited. I know it’s very easy to add RAM, but wouldn’t a default 2GB RAM render the experience more user-friendly? Especially for new users who may think that Whonix is buggy when it eventually crashes under a very reasonable workload.


#2

The first thing I do when importing the .ova is increase the RAM. I agree the default is rather low.

But, when making the comparison between the average hardware 4 years ago and now, you also need to consider that if your new users moved from Windows 7 to Windows 10 and from old versions of Office, Firefox etc to new ones, then those newer versions of software (or bloatware?) already make “good” use of any newer standards of memory.

I think increasing the default to say 1.5 RAM is a good compromise then :slight_smile:


#3

Im using the default settings with xfce , didnt get lags , where do you experience lag?

also what is your host OS?


#4

Open a few tabs, including of more demanding sites. Protonmail for example. Or news sites. Add GIMP with a few large images. A libreoffice document and similar. It’s not very difficult to get Whonix Workstation to stall in those conditions.


#5

Would you like to install wine and origin plus Battle Field One and check the speed maybe will hang or not?

ofcourse its going to be slow specially in KVM/Vritualbox case because there is no memory-balance like in xen/Qubes. So adjust the memory/Rams to your needs.

So by default 1 GB is enough for sane small privacy like browsing the net safely using TBB , reading your emails safely using Thunderbird, and maybe IRC/Hexchat or XMPP/CoyIM.

More than those , please adjust the RAMs.


#6

@onion_knight @maximilian1

I think we need a poll to understand our userbase’s baseline hardware specs. The main reason we chose 1GB as default is to make it usable for as many people as possible that have crappy hardware. O at least to allow someone who has 4GB RAM/ Quad core to run a pair of Whonix-Workstations concurrently.


#7

Taking it to extremes, thank you for making me smile :slight_smile:

I just want to make clear that the issue isn’t speed but the Workstation becoming completely unresponsive to the point it needs to be shut down.

The first time I encountered the issue (with default RAM) was with just Tor Browser open with a few tabs. Hardly anything that can be considered intensive use.

As I made clear, that’s exactly what I do.

I don’t have a problem then. The discussion is assisting new users that experience the Workstation hanging with no clear reason (no Battle field One :slight_smile: )


#8

I like OSs that don’t ask for a lot of memory. But again, as a new user I did experience some temporary frustration having the Workstation hang for no clear reason so I sympathize with that side too.

Perhaps just making the point of “default RAM being a bit on the minimal side and easily changed” more obvious, as an initial message during installation or first launch will do the trick.


#9

It lags to the point of freezing only with Tor Browser and a few open tabs.

For example yesterday while I was writing a post here on a fresh Workstation with 1GB ram.

Host was Debian Linux


#10

I understand that, but Whonix is now 64 bits anyway, and 4GB RAM only is now quite rare.

On this kind of hardware a CLI Gateway with a 2GB RAM Workstation will still do fine however.


#11

I opened this thread to discuss treating the cause rather than the symptom:


#12

@maximilian1 @TNT_BOM_BOM @onion_knight

Which images did you use?

KVM images currently use only 1 CPU core whereas Virtualbox uses 4.
This might also cause some differences.
It also depends on what your actually running in the VM or browser. As soon as I enable javascript on some sites it slows down things a lot.
But I also think the RAM for the Workstation can be increased, because we can spare some memory with XFCE on the gateway.


#13

vbox - xfce 9.8 , i didnt experience the freeze but it seems to be common issue among other users.


#14

Nothing recent, I experienced it on Whonix 13 (with VirtualBox) at the past a few times. Since then, no, but as mentioned I allocate more RAM to every new VM I import these days so can’t tell if things improved with W14 KDE / XFCE or not.


#15

HulaHoop:

I think we need a poll to understand our userbase’s baseline hardware specs.

What are good choices to answer the poll?


#16

total RAM:

1536

1792

2048


#17

1536, 1792 sounds quite geeky. Who has that amount of RAM?

I mean, aren’t we better off asking users “How much RAM do you have?”

  • less than 2 GB
  • 3 GB
  • 4 GB
  • 8 GB
  • 12 GB
  • 16 GB
  • more than 16 GB

Something like that, perhaps simplified?


#18

How much RAM do you have?

  • Less than 4GB
  • 4GB
  • 8GB
  • 12GB
  • 16GB
  • More than 16GB

How many VMs do you run in parallel?

  • Gateway and single workstation
  • Gateway and 2 workstations
  • Gateway and 3+ workstations
  • 2+ Gateways and 2+ workstations

#19

Maximum 4 choices on twitter.

More polls to come later on twitter and in Whonix forums.


#20