[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

i2p whonix workstation error: can't find site

Hi

Been all day trying to get i2p setup on a whonix workstation. Have reinstalled several times and tried reinstall about 5 times. If I can fix this, I’ll re-write the confusing guide.

Trying to use this guide: whonix/wiki/I2P#I2P_client_inside_Whonix-Workstation

I used the repos:

deb deb.i2p2.no/ stable main
deb-src deb.i2p2.no/ stable main

I made fresh worksation, sys-whonix and gateway.

Not sure if I needed to but I also followed: whonix/wiki/Tunnels/Connecting_to_Tor_before_a_proxy

And then edited sudoedit /etc/uwt.d/50_user.conf adding: uwtwrapper_global=“0”

And also did sudoedit /etc/torbrowser.d/50_user.conf adding: TB_NO_TOR_CON_CHECK=1
CURL_PROXY="–fail"

Also did sudoedit /etc/privoxy/config: forward .i2p 127.0.0.1:4444

And proceeded to use all Tor Browser setttings recommended in the guy.

However one of my questions is where it says uwt, am I supposed to buy a proxy and put those settings here?

Is this what’s causing “cant find site” errors?

Other then that I went through the wizard mentioned here: 127.0.0.1:7657/i2ptunnel/wizard

Tried both http and socks. neither works.

The router config page does pull up. Shows 100s of peers and that I’m connected. I can visit regular sites. But nothing that is *.i2p.

Does HTTPS have anything to do with messing up connection to localhost? Because I tried but can’t fund a way to turn it off or remove https everywhere from firefox.

Ty for the assistance!

Users reported I2P issues also in this forum thread:
I2P used to work in Whonix 15 now it doesn't in Whonix 16

Re-installation will most likely be futile, not helpful.

guy → GUI

No need. I2P in Whonix-Workstation worked earlier without that.

Very likely. Making https work on localhost isn’t easy.

This could be reseached as per https://www.whonix.org/wiki/Free_Support_Principle.

Probably should merge the threads. I’m too using qubes. Seems to be same problem.

Seems there is no way to permanently remove https-everywhere anymore in tor browser seems to be hardcoded now. But I made sure it was disabled using troubleshoot mode. Hopefully disabled but who knows.

However I tried your curl commands and get “could not resolve host” in terminal from various i2p links with only http. So definitely know it’s not an https redirect problem.

I also used all of xVx’s about:config settings, no luck.

Should I switch from the source distro to flatpak?

Other than that, I got freenet in another vm working using the vpn through tor method.

Should I switch to that method instead of this proxyifier method?

There is something I’m confused about. In this part of this guide: dds6qkxpwdeubwucdiaord2xgbbeyds25rbsgr73tbfpqpt4a6vjwsyd.onion/wiki/Tunnels/Connecting_to_Tor_before_a_proxy#uwt

It mentions "uwt uses torsocks. While the name torsocks implies it is Tor specific, it is not. You can point it to any socks proxy. " I didn’t do anything here. I though technically setting up proxyfier and adding
forward .i2p 127.0.0.1:4444 to sudoedit /etc/privoxy/config
is somehow the proxy?

Should I be buying an actual proxy or could I just use my vpn like I did with freenet?

That’s the only thing I think I missed is that I should’ve setup an actual external third-party proxy at the end. Which hopefully VPN through tor would work too.

ty.

and guy → GUI → guide* :slight_smile:

Wait I’m totally confused now. And missed this part of your message. Sorry my screen is very tiny. So if I understand correctly I shouldn’t be using Proxyfier turning off uwt wrapper?

And now I just read that Proxyfier and Privoxy are different? I think that’s where I messed up. I thought these were the same.

I’ll go back and do it again without the proxyfier and uwt stuff. Will report back.

Doesn’t work. Switching to i2pd flatpak.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]