[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

I2P used to work in Whonix 15 now it doesn't in Whonix 16

long time whonix user and supporter here hi :slight_smile:

On whonix 15 i used a guide created by Desnake from Alphabay which went like this

Run the following code:

sudo apt-get install apt-transport-https -y;wget -q -O - https repo.i2pd.xyz/.help/add_repo | sudo bash -s -;sudo apt-get update;sudo apt-get install i2pd -y;sudo service i2pd start

The above command installs secure package installation with HTTPS, gets signing keys and imports them, updates packages to recognize your newly added repository, install i2pd and then start the i2pd service.
In Tor Browser or your Firefox, type about:config into the URL bar, accept the warnings and press Enter. Make the following changes:

extensions.torbutton.use_nontor_proxy true

After setting extensions.torbutton.use_nontor_proxy to true your browser might restart to apply changes. Apply the following changes where the first is the setting you have to search and after the space is the value you want to have:

 network.proxy.http 127.0.0.1

network.proxy.http_port 4444

IMPORTANT: Wait 2-5 minutes depending on your network in order for I2P to connect properly otherwise if you try instantly it might say that the host is unreachable.
You are now able to browse i2p websites. On Tor Browser/Firefox it is important to add http:// infront of the i2p site otherwise you will search it instead with duckduckgo or other search engine which you have set.

For other Linux flavours find the most recent I2Pd documentation. i2pd is an established alternative i2p software which is the same as the original software however it is written in C/C++ and provides faster connection, less resource-hungry on the CPU/RAM etc. After installing i2pd either from source or from repository, you can proceed to the step where you modify Firefox/Tor Browser.

Now i can’t get it work on whonix 16 it installs correctly and when i visit say http zzz.i2p or http stats.i2p it loads them alright but when i visit other sites or alphabays url tnaefzkcnhryeusi7hdpqujqiqmnbtah3dmjcg3gvezohunjuxbq.b32.i2p it fails for some reason? I tried restarting installing reinstalling new template new connection nothing works! The same url on whonix 15 with everything installed i checked right now works perfectly? I used curl to get more information with the -o parameter and got curl: (6) Could not resolve host: If I try on the browser it says Hmm. We’re having trouble finding that site. but the site is up i can see it on whonix 15

To confirm it’s an issue with whonix i started my Tails usb and used the custom script by desnake to enable i2p on there. It worked perfectly and the eepsite was displayed while it was unreachable in whonix 16!

I’d like some help with this please!

An annoying thing i’d like to add is tor browser constantly puts https:// infront of i2p links can we add something to recognise it as .b32.i2p and not put https? Really annoying when browsing forums like zzz.i2p

Anything helpful on this wiki page…?

Try:

curl.anondist-orig

Instead of curl. Then of course append the rest of the curl command line.

This is related to stream isolation.

The Whonix project doesn’t develop Tor Browser. Upstream is The Tor Project developers Tor Browser. That part is therefore unspecific. You could request this feature from upstream.

With

curl.anondist-orig

i can’t make the curl request my original request is as follows

curl -o -x 127.0.0.1:4444 http://tnaefzkcnhryeusi7hdpqujqiqmnbtah3dmjcg3gvezohunjuxbq.b32.i2p

i’ve indeed tried all of the options on the page you referred me to even installing it but it doesn’t work on whonix 16! I’d like to mention i used i2pd previously as per the guide and it was super easy to do it compared to the official software.

Is this command functional elsewhere?

curl.anondist-orig -o -x 127.0.0.1:4444 http://tnaefzkcnhryeusi7hdpqujqiqmnbtah3dmjcg3gvezohunjuxbq.b32.i2p

Did you try above command?

curl syntax seems wrong.

says couldn’t resolve host the syntax is correct… any ideas how to fix this or what was changed? i tried again with whonix 15 and the site and other i2p eepsites worked

Nothing related in Whonix changed as far as I know.

@knoglez did you resolve this issue? I’m having the exact same problem. I’ve been trying to fix it for two days to no avail.
@Patrick I’ve attempted the same method as knoglez on both a Whonix Virtual machine through windows and Qubes-Whonix through QubesOS. Have you been made aware of any changes since this post?

No.

i2pd flatpak is working for me on Qubes-Whonix 16. Install as user in AppVM:
flatpak --user install flathub website.i2pd.i2pd

In TorBrowser, disable https-everywhere extension. In about:config change:
network.dns.offline-localhost–>false
network.dnsCacheEntries–>0
network.dnsCacheExpiration–>0
network.proxy.no_proxies_on–>1
network.proxy.share_proxy_settings–>true
network.proxy.ssl–>127.0.0.1
network.proxy.ssl_port–>4444
browser.fixup.fallback-to-https–>false

All of those may or may not be necessary but, looking back at my modified prefs, that’s what worked for me.

As for the toolbar search issue, also in about:config, change:
keyword.enabled–>false
browser.urlbar.suggest.searches–>false

1 Like

Hello, I was originally trying the whonix guide which didn’t work. I was sent to this thread. Trying your method. I’ve got the i2pd gui installed. It says connected
Routers: 275 Floodfills: 186 LeaseSets: 0
Client Tunnels: 41 Transit Tunnels: 0

But when I try to goto router page in tor browser or any .i2p sites it just states “unabled to connect”.

Before in the whonix guide it mentions all these proxy settings, privoxy, proxifyer, I didn’t do that here. Just your tor browser settings and installed i2pd from flatpak. Is there more i should do this time around? I’m also using whonix workstation on qubes for this. Thank you kindly for your advice.

1 Like

Your connection to the i2p network appears to be ok. In TorBrowser about:config, ensure you’ve changed these values as well:
extensions.torbutton.use_nontor_proxy–>true
network.proxy.http–>127.0.0.1
network.proxy.http_port–>4444

Now, try visiting a stable i2p site such as http://stats.i2p or http://zzz.i2p. If you can see those, then TorBrowser is configured correctly to access i2p.

With i2pd, there is no router config page at 127.0.0.1:7657. The flatpak gui app is in essence the router config.

1 Like

I’ve change the wiki Invisible Internet Project (I2P) from no longer working installation from packages.debian.org (i2p package no longer available for Debian 11 bullseye) to installation from official I2P APT repository.

Anything incomplete in the wiki? Could you please edit the wiki to add any new / additional / different (?) settings which are required nowadays?

(Anyone can edit the wiki. With or without account. → Improve the Documentation / Edit the Whonix ™ Wiki)

Okay these last three settings did it.

Actually I misread, and at first only entered
network.proxy.http>127.0.0.1
network.proxy.http_port>4444

Which didn’t work only at first!

Then reread and saw extensions.torbutton.use_nontor_proxy>true. After entering that it worked. So definitely need all those three settings.

However there seems to be still something strange going on with https.

If it takes a site too long to load, it seems to try to redirect to https. Then I can never get to the site again as it always tries to goto https.

I found this site: http://reg.i2p/alive/

Which seems to be a directory. And I’m just clicking whatever is stated at being alive. Now disclaimer I don’t know what these sites are so just clicking randomly to test. So forgive me if there’s something offensive there.

Thus far I’m able to get to some sites. But for some reason cannot currently see:

in.i2p
http://isitup.i2p/
darknetnow.i2p
aaaaaaaalivetalkzzzzzzzz09allarxmetarootsznzarxpostmetasymbol.i2p

Only listing them to figure out why I can visit some sites and not others in case others can visit them. Is it maybe these sites actually have https installed? Or maybe at the time of writing these sites are actually done. I don’t know.

But I can’t figure out why when I add http://isitup.i2p, it always changes to https then the site won’t load.

Currently https everywhere plugin is disabled.

And I’m usually the following recommended settings all listed above.

I tried looking in to if tor browser has a cache, it seems to be limited to the session only. So I cleared everything and restarted the browser. Still redirects to https.

Other than I’m glad to get some functionality out of the system and now I can learn more about i2p on whonix! Thank you for the assistance thus far! You guy have been a real help :slight_smile:

By the way this experience is very nostalgic. Because of the decentralised aspect you’re searching for lists of links. Some sites are already down. You feel surprised when you get an up to date list link.

And most of these sites seem to be purely html. It’s like using the internet again for the first time in the 90s when there were no search engines. Very old school. Very cool :slight_smile:

Just tested two things. When there’s no internet sites like http://zzz.i2p/ automatically redirect to https. But when there’s internet, it will go back to not redirecting and accepting a connection to http://zzz.i2p.

However these site darknetnow.i2p/, isitup.i2p, in.i2p no matter what I do redirects to https. So as far as my limited knowledge can tell this site either requires https and I messed something up in setting up in i2pd or tor browser preventing it from establishing a secure https connection. Or there is a cache that I don’t know about in i2pd, tor browser or whonix workstation. Or those sites are actually down and there is some auto redirect setting still active in tor browser that I haven’t figure out how to disable :frowning:

I can edit it to include the flatpak solution. Is that considered foreign?

1 Like

Foreign: both, flatpak and upstream I2P repository is considered foreign from perspective of Whonix.

But I2P repository from geti2p is the official repository and flatpak is inofficial?

Hence, I2P repository version should be preferred. Any reason against it?

i have updated I2P wiki to the latest configs, dropping privoxy need and just making TB work with I2P nicely, fixing the force https…etc.

But there is a note need to be taken care and i have created a ticket about it which is you cant enter I2P eepsites and on the same time entering I2P console (127.0.0.1:7657) due to this issue:

1 Like

correct

nope, its just third party repo thats it (similar to TPO with Tor).

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]