[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

How can I watch youtube in Whonix Workstation?


#1

Hi,
How can I watch youtube in Whonix Workstation? None of the browsers support it. Nether Firefox nor Chromium that I installed myself.
Is there any way to make it work?


None of the browsers play online video on Whonix-Workstation
Am I the only one who has a problem with Youtube in Whonix Workstation?
#2

Good day,

Under normal circunstance, watching Videos should be possible with any browser if JavaScript is active and the VRam set accordingly.

Have a nice day,

Ego


#3

Thanks for the answer. I wonder if you could point me in the right direction of how to do it. (i’m not an expert on this subject). Thanks in advance.


#4

Good day,

Simply turning of NoScript in the Tor Browser Bundle should be enough to watch Youtube Videos.

Have a nice day,

Ego


#5

Ttied that - nothing. Nothing works in my case. Not the Tor browser with NoScript off, nor the Firefox, nor the Crhomium. I’ve installed all kinds of plugins in Firefox for HTML5 - same result.
Why is it like this? A simple video in simple Youtube is suddenly an issue? Can anybody resolve this at all??
I’m using Virtualbox, like most the people here, I believe. Am I the only one to have that problem??


#6

Good day,

Usually Youtube should Showcase some Kind of error in that case. Is there nothing? Also, what Kind of Settings do you have under Graphics?

Have a nice day,

Ego


#7

Hi Ego, thanks for answering.
The video as if appears to start but it never does and it holds. No errors it’s just frozen, a motionless picture. I can drag the slider and get pictures of the clip but it does not stream.

As far as graphic I tried default - nothing. I tried to enable everything I could - nothing either. Now I have full video memory of 128 MB and 3D acceleration on, but it simply ain’t working.
I’m on Dell XPS 13
Any ideas?


#8

Good day,

Then I have no idea where the issue may lie. Did you try reinstalling VBox and did you verify the Images?

Have a nice day,

Ego


#9

Can anybody from this community help me with Youtube video? None of the browsers provided support it. It just freezes - no streaming. How come such a trivial thing as Youtube is not supported? I tried all kinds of plugins for Firefox and Chromium that installed - nothing works.
Does this distro at all support Youtube? Can anybody suggest what to do?


#10

Good day,

Just merged the threads, there is no sense in creating two threads for the same question.

Furthermore, Whonix Supports YouTube without issue. Under a similar configuration, I, as well as many others, can use it without issue.

Have a nice day,

Ego


#11

Than what is wrong with my setup? My host is on KDE as well (Kubuntu). What can possible be wrong? I searched "“debian+youtube+issue” and get nothing, as if Google does not know about it. As if I’m a sole person on this planet to have such an issue.


#12

None of the browsers plays on-line video on Whonix-Workstation.
Can someone help?


#13

what, there is nobody here who can help??? No video support in the browsers - not possible to use Youtube in none of the browsers and nobody gives a damn??? Why is called “support” then?


#14

Good day,

I already told you, creating a new thread for this won’t get People to help you faster.

If you’d use the Forum search you’d know that other People can use Youtube on Whonix in a similar Setup just fine.

Here is an example: Tor Browser can't play MP4 files

YouTube is working using HTML5.

It works fine for a lot of other People, including myself, so there is no one who can help you since this isn’t a known issue.

Yes, nobody can help, since you give no Information. I already asked you in post #7 whether you’d verified the Images and reinstalled VBox.

You ignored that.

Also, if you really want to figure out whether the issue lies with Whonix, try this: Set up a Debian VM on your System. Try Youtube on there. If it doesn’t work, we know where the issue lies.

Have a nice day,

Ego


#15

If I may suggest a test. Start a new VM and install another OS. Then see if you can view Youtube videos in it with a plain browser. Maybe that is a good place to start.


#16

https://tails.boum.org/support/faq/index.en.html#index28h2


#17

On Tor Browser, you should both turn NoScript off and set the Security Level to “Standard”.

YouTube videos will not play (for me at least) with the “Safer” and “Safest” settings.