Whonix Wiki Download Docs News Support Tips Issues Contribute DONATE

Hash Sum mismatch, downloads all fail... since Win10 2004 update

I’ve been running Whonix over VirtualBox on Windows 10 home x64 for a month and it ran perfectly, up until, the big update from Microsooft a few days ago. I’ma newbee.

Now, both gateway and workstation… Terminal / sudo apt-get update && sudo apt-get dist-upgrade / I get many hash sum mismatch. Also, It can’t even download/update the TOR browser. Whonix is now a virtual paperweight.

I’ve tried creating new vm’s without messing with any of the seetings [fail]. I’ve tried reinstalling VirtualBox, latest version, and a bunch of older versions [fail]. My Windows 10 networking is running great, I can download and stream to my hearts content using any other software than Whonix.

I’ve been a Windows person for nearly 30 years, I am lost when it comes to debian/linux. I’m hoping many other people are experiencing the same problem and that a fix will be forthwith.

And the waste of time reading suggestions off the interweb:
sudo apt-get-update-plus dist-upgrade
sudo rm -rf /var/lib/apt/lists/*
sudo apto-get clean
sudo apt-get update
sudo apt-get-update-plus dist-upgrade
sudo rm -rf /var/lib/apt/lists/partial
sudo apt-get update -o Acquire::CompressionTypes::Order::=gz
sudo apt-get-update-plus dist-upgrade
Good Grief!! ugggh!!
Thank you.

Most files [using sudo apt-get-update-plus dist-upgrade] are downloaded without Hash Sum mismatch, yet other don’t. Is the primary or mirror bad?

The ones that fail to download [Hash Sum mismatch] are:
tor+https://deb.whonix.org buster/main amd64 monero-gui all 0: [96.1 MB]
tor+https://deb.debian.org/debian-security buster/updates/main amd64 linux-image-4.19.0-9-amd64 amd64 4.19.118-2+deb10u1 [48.2 MB]
tor+https://deb.debian.org/debian-security buster/updates/main amd64 linux-headers-4.19.0-9-common all 4.19.118-2+deb10u1 [8,371 kB]
tor+https://deb.debian.org/debian-security buster/updates/main amd64 libjavascriptcoregtk-4.0-18 amd64 2.28.2-2~deb10u1 [5,373 kB]
tor+https://deb.debian.org/debian-security buster/updates/main amd64 libwebkit2gtk-4.0-37 amd64 2.28.2-2~deb10u1 [12.7 MB]

I solved my problem, it was the Windows 10 Core Isolation feature, it was turned on for some reason.

It is nice to have the Windows 10 OS lookout for potential shenanigans
but if the safety settings “brick” other applications like VirtualBox, I just say WTF.

I hope this will help any other Windows 10 people, if there are any still remaining.


Notice: Reboot the PC when ever it displays a reboot suggestion.

  1. BIOS// Verify BIOS that SMV was enabled.
    CPU CONFIG tab / select SMV MODE / set it to ENABLE.

  2. Boot PC Windows 10.

  3. Win10// searchbar “Windows Features On Off” // open it //
    uncheck [ ] Virtual Machine Platform
    uncheck [ ] Windows Hypervisor Platform
    !-- I hope this doesn’t mess something else up --!

  4. Win10// searchbar “cmd” prompt, with admin powers: bcdedit /set hypervisorlaunchtype off
    [if you want to later enable it… bcdedit /set hypervisorlaunchtype auto].

  5. Win10// searchbar “Core Isolation” // open it // Memory integrity = off.

After all the changes and verifications above, and PC rebooting, launch VirtualBox and
run Whonix Gateway first, I always change the time in the tray first. Next
bring up terminal, sudo apt-get update && sudo apt-get dist-upgrade
and it will install without ‘Hash Sum mismatch’ and will download files without failing.

Then run Whonix Workstation, I always change the time in the tray first.
Next bring up terminal, sudo apt-get update && sudo apt-get dist-upgrade
and it will install without ‘Hash Sum mismatch’ and will download files without failing.

Run TOR webrowser and it will download/update without failed download message.

End of story

1 Like


This we have here:

but I wonder why this setting changed itself during Windows upgrade. Haven’t heard that before.

Interesting. That sounds like it could interfere with VirtualBox indeed.

Like to add here https://www.whonix.org/wiki/VirtualBox/Troubleshooting ?

Hm, no GUI way to do that?

If you are using Windows Subsystem for Linux, this will break your virtual systems. I had to re-enable “Virtual Machine Platform” to fix. Just an FYI.

VirtualBox Core Isolation (also called Windows Hypervisor-enforced Code Integrity (HVCI)) issues should be fixed in VirtualBox version 6.1.32 (and above). Quote VirtualBox changelog:

VMM: Changed the guest RAM management when using Hyper-V to be more compatible with HVCI (bug #20627 and #20694)

Could you please confirm that Windows Core Isolation is no longer an issue?

This also got finally a dedicated documentation chapter: