Core Isolation in Windows 10 breaks Whonix

Core Isolation in Windows 10 breaks Whonix in several ways.

Does anybody know if this is a Whonix problem or a VirtualBox problem?

When having Core isolation activated I get problems with:

Booting, I get an error stating “bug” somthing “CPU” something “29s”

Freeze during boot.

It takes 3-6 boots just for entering Whonix

Sometimes after boot the mouse will not move with the need to reboot.

Updating TOR-Browser in the browser is crashing after the Browser does an exit to start installation, leading to TOR-browser will fail to start so you need to install it with command line.

Some crashes now and then with an unresponsive Whonix but a responsive VirtualBox

This means that you will not be able to use Whonix in Windows 11, because Core Isolation is mandatory in Windows 11.

1 Like

VirtualBox issue.

(Whonix is based on Kicksecure.)

Upstream virtualbox.org is very most likely aware of it:
virtualbox.org • View topic - Can't install on Windows 11

VirtualBox forums are full with mentions of core isolation. Search term:

site:virtualbox.org core isolation

But I am not sure which ticket is tracking VirtualBox with Windows core isolation compatibility. Perhaps:
https://www.virtualbox.org/ticket/16801

1 Like

Thanks. Seems as for now, the only solution is to turn core isolation off. Virtualbox devs are, since earlier, aware of the problem.

Please see:

https://www.kicksecure.com/wiki/VirtualBox/Troubleshooting#Core_Isolation

1 Like

systemd hang/kernel panic gonna hit any OS which going to be installed inside vbox while core isolation on e.g:

Tried this with whonix,kali,arch,debian same result (the message may differ as shorter/longer but the result is the same)

1 Like

Was Windows updated?

yes

1 Like

latest Vbox upgrade version 6.1.36 fixed the issue.

1 Like