Black Screen on Boot

I installed Whonix-XFCE back in August and it’s been running great until a couple weeks ago.
Now both the Gateway and Workstation boot to black screen. They start to load, and after it gets to Loading Ramdisk it goes blank.

I’m running VirtualBox 6.1.32
The Workstation is set with 16GB of the 32GB total. 2 of the 8 Processors, and 128MB Video Memory.

I tried booting with different controllers, and then I removed the controller, booted, and added the controller back.
When it came back up I was able to see something.
/dev/sda1: recovering journal
/dev/sda1: Clearing orphaned inode 6101905 (uid=1000, gif=100, mode=0100644, size=32768)
/dev/sda1: Clearing orphaned inode 6101845 (uid=1000, gif=100, mode=0100600, size=64)
/dev/sda1: clean. 710032/6553600 files
(1 of 3) A start job is running for Load AppArmor profiles (1min 1s / no limit)
[127.904066] EXT4-fs error (device sda1): __ext4_get_inode_loc:4721: inode #2884774: block 11534442: comm systemd-udevd: unable to read itable block
[127.905280] EXT4-fs error (device sda1): __ext4_find_entry:1449: inode #2884051: comm systemd-udevd: reading directory lblock 0
[127.957005] EXT4-fs (sda1): Remounting filesystem read-only
When I let it run for a while I came and it had a screen full of errors saying something like:
watchdog: BUG: soft lockup - CPU#1 stuck for 23s

Any idea what’s going on and/or how to fix?

I downloaded and Imported the Gateway and Workstation. The Gateway booted up and set up just fine.

The new workstation is also booting to black screen, so it doesn’t seem to be specific to my one VM.

General VirtualBox Troubleshooting Steps

(Whonix is based on Kicksecure.)

I saw that before, but there really isn’t anything useful there to help resolve the issue.
It’s basically “Use the latest Kicksecure” and “Update the system”
I want to use Whonix as it’s more secure, and it has the gateway, and I can’t update anything if I can’t get into the system.

For shits and giggles I downloaded Kicksecure and tried it. It’s coming up to a black screen as well. So it’s going to be a setting, or something going on with my PC. I haven’t done anything in the past few weeks other than upgrade Windows 10…

Please mention the steps and the results of these steps.

You should try reinstalling Virtualbox as latest one is 6.1.34.

1 Like

Please state the number of each troubleshooting step and the result of it.

No. For example:

Windows 10 users only: Core Isolation: At time of writing, VirtualBox does not support core isolation. Disable core isolation.

Please see: