Gateway tor problem latest update


I’ve tested this on several machines all using Whonix 13.

After an update today the gateways will no longer load Whonixcheck and just throw an error up saying /etc/tor/torrc is configured incorrectly.

If you # out the following:
HiddenServiceDir /var/lib/tor/hidden_service/
HiddenServicePort 80

Then the error will go away, so it’s throwing the error up in relation to these two lines.


Good day,

Did you setup a hidden service before?

Have a nice day,



Several, this error has just began today after I updated the gateways, it only throws the error on the gateway Whonixcheck, the hidden services still work but the gateway won’t run no further Whonixchecks.

I have tested it on both a vps and dedicated server the error is on both after been updated.

I’m pretty sure one of the updates was the torgeoip thing didn’t this cause an error in the past if memory serves me correct.


Please post your [redacted] torrc. Please post the whonixcheck error.


The error is this.

error: Tor config Check results
Your /etc/tor/torrc file contains at least one error.

(tor exit code:1)

You have to fix this error before you can use tor

[notice] Read configuration file “/etc/tor/torrc”.
[warn] Directory /var/lib/tor/hidden_service cannot be read: Permission denied.
[warn]Failed to parse /validate.config. Failed to configure rendezvous options see log for details


My torrc file is very Whonix generic

DisableNetowrk 0

HiddenServiceDir /var/lib/tor/hidden_service/
HiddenServicePort 80

If I comment out the hiddenservice section of the torrc file, Whonixcheck will then run.

This only started after I updated my Gateways today until today for at least three months I have never seen this before.


Good day,

I think I see the issue. Your torrc contains the line:

HiddenServicePort 80 10.152.152:80

Which contains an incomplete IP. It actually should be:

HiddenServicePort 80

Have a nice day,



Sorry that’s my bad it does have

I just copied it down wrong I’ll edit that post.

It’s also happening on two different machines in two separate locations, one a vps and one a dedicated server so I think it’s some kind of bug and not user error, both machines have different hidden services unrelated to one another.

Both worked perfectly until I updated the gateways today, whonixcheck ran fine at first alerted me that an update was ready once I installed the update, it popped up the error listed above on both machines and neither machine will run Whonixcheck again until I # out the hidden service lines.

I have just ran the update on my host machine and the following tor files are to be updated

tor & tor-geoipdb.

The error has now also started on my host machine after the update


see here


Please post your folder permissions.

sudo ls -la /var/lib/tor


sudo ls -la /var/lib/tor/hidden_service


First image:
you got a typo.



Correct your torrc to:


Second image:
Please post your folder permissions as requested in my previous post.


Ok I’ll do that now one second.

These ss are from my host machine I quickly took the pic and noticed the typo after I posted it, It makes no difference though that is not causing the issue, I corrected it and of course and re-uploaded a new screenshot, the issue is also persistent on my vps and dedicated server too.

I will do as you requested now and edit this reply one moment


Any AppArmor denied messages?

sudo grep DENIED /var/log/syslog


Same error if you manually run that command?

sudo -u debian-tor tor --verify-config


I guess not. And if not… It’s a whonixcheck AppArmor bug since it has no permission to read /var/lib/tor/hidden_service.


Ok I ran both commands here is the results.



Bug confirmed. Working on a fix.


You’re the man thank you.



whonixcheck_4.6.4-1_all.deb is now available for testers from Whonix jessie-proposed-updates and testers repository suites.


I have a similar issue and i checked /etc/apparmor.d/usr.bin.whonixchech is already fixed.here is a screenshot of the error: basically I was messing around with hidden service and i think i messed up the permissions for /var/lib/tor/.tor.