[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

gateway can't connect tor in kvm

Hello…
When i used arch host all were right. Now im using debian host.
If i don’t add dhcp and forward to enp2s0 network isnt working, dont mind it. My whonix gateway haven’t network connection, but my other vms with whonix-external network have(without whonix, only virtual network). What should i do?

I ran into the same problem before. You need to enable DHCP for the host connection in network manager (doesn’t matter if WiFi or Ethernet) for the VMs to connect. Libvirt networking seems to need it.

As for why Whonix doesn’t connect while others do, could be an overlap of static addresses or maybe by having dhcp clients, the other VMs resolve their connection problems somehow. This didn’t seem to matter in my case.

Re-enable DHCP on the host.

1 Like

Thanks, but Dhcp isnt main problem. Only whonix havent connection, if i connect other vms(debian, ubuntu server) to whonix-external network they have internet.
English isnt my main language, sorry.
I want try your offer, but tommorow.
It is strange, becsuse ONLY whonix. I lovr u system, i hope it will work…

And i dont understand all, ehat you sayd, sorry

Then try installing a dchp client on the GW, but understand that it increases your attack surface. This is the only difference between Whonix and the other VMs you listed.

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]