KVM DHCP refuses to work - No DHCP client software found!

I changed and restarted Whonix-Internal:

<network connections="2">
  <name>Whonix-Internal</name>
  <uuid>btw-should-i-hide-this?</uuid>
  <bridge name="virbr2" stp="on" delay="0"/>
  <mac address="is:this:my:device:mac:address?"/>
  <ip address="10.152.152.0" netmask="255.255.192.0">
    <dhcp>
      <range start="10.152.128.1" end="10.152.191.254"/>
    </dhcp>
  </ip>
</network>

Although I’m not sure if the line sudo nano /etc/network/interfaces.d/30_non-qubes-whonix applies to Gateway or Workstation (It’s confusing, logically it would make sence to change eth0 on Workstation, but commented eth0 dhcp lines and comments about them are in the both files), I tried changing it on both (but one at a time: having iface eth0 inet dhcp on one VM, while having iface eth0 inet static on the other) but got the same error on both VMs:

% sudo ifup eth0
No DHCP client software found!
ifup: failed to bring up eth0
zsh exit 1

As I understood from this, the dhcp should work out-of-the-box without additional dhcp package, right?

Is this related to this comment? I couldn’t find an answer there.

Also, regarding the other comment,

what exactly does this refer to? My wifi connection has Automatic (DHCP) in NetworkManager (nm-applet). I also have the virbr* connections listed in my host os ifconfig, ip addr and NetworkManager. The interesting part is the connections referring to Whonix-External and Whonix-Internal:

Seems like I need to change one of them similar to how I changed the xml. If so, which mode should I choose (ManualAutomatic (DHCP) or Automatic (DHCP) addresses only ?) and what should I put in which box?