[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Error starting domain: unsupported configuration: host doesn't support paravirtual spinlocks

@onion_knight in Whonix Desktop Installer with Calamares - field report

Did this also happen for you if you used KVM “normally” “as a normal user” as per the usual instructions on https://www.whonix.org/wiki/KVM on Debian buster hosts?

No, this only happens using the Whonix-Host system.
This is probably related to this commit:


pvspinlock was set to on.
All my physical machines (on debian buster btw) were configured before this change, so they are not affected by this.
I will try to change this setting to ‘on’ on my debian buster machines to see if it also fails.
Meanwhile, reverting this setting to ‘off’ solved the problem on the Whonix-Host system (more on this later, still testing).

1 Like

Maybe caused by the same issue: VMs do no start until the CPU configuration is set to “Copy host CPU configuration”
Will try to test tomorrow and see if it works once the domain type is changed from ‘qemu’ to ‘kvm’.

1 Like

I confirm the error ceases when using domain type=‘kvm’ instead of ‘qemu’.
Fixed.

2 Likes

I have the same problem but enabling Copy cpu host configuration doesn’t help. Domain had been set to “kvm” already. Using Arch with virt-manager.

@xuy What problem? If its pvspinlocks just edit it out. I’ll add this to the known problems section if that’s the case.

Yeah, paravaritual spinlocks. Ok, I have disabled them by editing xml, it works without them but i’m not sure, would it affect security/performance? And is this problem related to my system or xml preconfigured in bad way?

Theoretically performance.Your system seeks to be missing the kernel support for it it is not the fault of the config as this feature has been around since forever and is supported elsewhere.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]