[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

ERROR: qemu does not support the accel2d setting


#1

Hi,

I followed the instruction but get a “qemu does not support the accel2d setting” error when I try to run.

Any ideas? Thanks.


error: unsupported configuration: qemu does not support the accel2d setting
#2

Seems you are running a very recent version of QEMU-KVM. The devs have added XML checks that fail hard if graphics acceleration settings are chosen which aren’t supported. accel2d was only ever relevant to VBox. accel3d becomes relevant when the QEMU version that supports virtio-GPU lands in Debian stable. The guest must also be running a recent kernel and version of mesa to take advantage of the new feature - aka when Whonix is based on Debian Stretch.

https://www.mail-archive.com/libvir-list@redhat.com/msg129244.html
https://www.mail-archive.com/libvir-list@redhat.com/msg129278.html

I’ll fix it in the XML. Here’s what you need to do:

Edit the vm settings and remove:

< acceleration accel3d=‘yes’ accel2d=‘yes’/>


#3

Thanks! That did it.


#4

Same here on Fedora 26. Removing the line resolved it.