[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

error: unsupported configuration: qemu does not support the accel2d setting


#1

im using debian 9 and i have followed kvm instructions for installations inside and there r 2 steps cant be done:-

root@user:/home/user# virsh -c qemu:///system define Whonix-Workstation*.xml
error: Failed to define domain from Whonix-Workstation-13.0.0.1.4.xml
error: unsupported configuration: qemu does not support the accel2d setting

and also:-

root@user:/home/user# virsh -c qemu:///system define Whonix-Gateway*.xml
error: Failed to define domain from Whonix-Gateway-13.0.0.1.4.xml
error: unsupported configuration: qemu does not support the accel2d setting

and if i install whonix-gw inside the kvm manually the gateway wont connect to Tor.


#2

oh ok found ur answers in here:-

also this link is useful:-

@HulaHoop i think u need to pin this issue until the issue fixed.


#3

Libvirt devs recently changed it to fail hard when detecting that these deprecated video settings are included in the config files. To have it work, get rid of ‘< acceleration accel3d=‘yes’ accel2d=‘yes’/>’ with the command: ‘virsh -c qemu:///system edit Whonix-Gateway’

Then do the same with the workstation:

‘virsh -c qemu:///system edit Whonix-Workstation’

Yes it already fixed for Whonix 14