[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Err:11 https://deb.whonix.org buster InRelease - signatures couldn't be verified because the public key is not available:

Looks like it’s broken again, running sudo apt update shows

Err:11 https://deb.whonix.org buster InRelease                                 
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY CB8D50BB77BB3C48

This is different from sudo apt update - "NO_PUBKEY CB8D50BB77BB3C48".

Whonix 15 / buster based Whonix is has been deprecated.

Thanks for the link. I’m not using Whonix, only using their repo to get the Monero software.

I’ve updated my /etc/apt/sources.list.d/whonix.list file to look like the following (changed buster to bullseye, which I got from the Debian Releases page):

deb https://deb.whonix.org bullseye main contrib non-free

But sudo apt update is still showing a similar message:

Get:19 https://deb.whonix.org bullseye InRelease [39.6 kB]
Err:19 https://deb.whonix.org bullseye InRelease                                               
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY CB8D50BB77BB3C48
W: GPG error: https://deb.whonix.org bullseye InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY CB8D50BB77BB3C48
E: The repository 'https://deb.whonix.org bullseye InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Any idea what might be going wrong? While I’m at it, is there anything I can use for my whonix.list source so that I don’t need to update it when Whonix gets a major release as well?

Thanks,
dginovker

Not happening for other users currently, apparently.

Your (VM) clock might be to slow or fast.

1 Like

Strange, this is my host OS and it’s working fine otherwise. Only thing that might be off is I’m in an uncommon timezone, but doubt that’s it.

If I get any more info, I’ll update the thread and ping you.

Just tested this now, working perfectly on debian 11, Following this instructions: (in case you followed other)

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]