[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Can't install Whonix in KVM


#1

Hello
I have tried to install whonix in KVM, but the result is:

Sea bios …
Machine UUID …
IPXE…
Booting from Hard Disk
Boot failed: not bootable disk
No bootable device

I changed also ‘storage format’ in qemu option from raw to qcow2 but give me an error.
Do you’ve any tip?


#2

Good day,

sorry, but does this apply to the workstation, the gateway or both? And did you verify the files?

Have a nice day,

Ego


#3

Hi Ego
Yes, this apply to both, files are verified.
After extract with ‘‘atool -x’’ command, the files are large 101GB but when I run the command ‘‘du -x Whonix-Gateway-*.qcow2’’ to see the real size it shows me always 101GB (I don’t believe that this is the problem)
I have download Whonix three times but nothing
Is the problem in virt-manager?

Regards


#4

Good day,

sorry, but why do you use commands different from the setup guide? Please use the method explained here: https://www.whonix.org/wiki/KVM#KVM_Setup_Instructions

Have a nice day,

Ego


#5

Good day

Unfortunately also using ‘‘tar’’ the result doesn’t change

Regards


#6

just follow these photos with their commands , u gonna have KVM installed with no mistakes (if u r using Debian)

https://www.whonix.org/wiki/KVM/Installation_Screenshots


#7

Hi TNT_BOM_BOM

I use ubuntu, I think that KVM is installed perfectly because when I run another ubuntu in it, works well


#8

well choosing ubuntu for anonymity = bad choice

some of the problems happened inside ubuntu when installing kvm inside but not for example debian = which is weird

but check ask Ubuntu , or check this link it may help u.

lastly, check ur Bios and c this link


#9

I have switched to Debian (hoping to haven’t problems). During installation I have choose to not allow root login, done automatic partition and when was encrypting the volume I cancelled inserting only passphrase. Do these choices weaken the security? (this is the first time that install Debian)

Regards

About your question, I already did this step before to install KVM, this is the result:
INFO: /dev/kvm exists
KVM acceleration can be used


#10

After the installation, plug the usb HDD but Debian doesn’t start (opens a black screen with a flashing line on the top left). Grub is installed in the external HDD, but it’s as if there weren’t.

Regards


#11

this isnt related to kvm anymore , but anyway to solve ur problem i think u need to fix grup by using for e.g Boot-Repair.


#12

Hello
Resume this topic because I want an explanation.
In the guide of the Debian installation there is this command but it’s invalid:
sudo ln -s /etc/apparmor.d/libvirt/TEMPLATE.qemu /etc/apparmor.d/libvirt/TEMPLATE.kvm
Have I to change TEMPLATE with anything?

Then there are
virsh -c qemu:///system net-autostart Whonix
virsh -c qemu:///system net-start Whonix
Do they refer about start whonix when I turn on the PC?

Thank you


#13

what do u mean guide of debian installation? kvm-debian guide or what ?

Do they refer about start whonix when I turn on the PC?

nope. whonix wont start automatically unless u run it by urself.


#14

kvm-debian guide


#15

no clue , without images or error messages i cant tell what it is going on with u


#16

I’m being affected by this same problem. I’ve tried installing both 13.0.0.1.4 and 14.0.0.2.6 in Debian Stretch and got these same results. In both cases, I followed this guide (http://kkkkkkkkkk63ava6.onion/wiki/KVM), the only thing I’ve done differently is to download alternative packages for libvirt-bin, as suggested by apt:

[sudo] password for thoreau: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libvirt-bin is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libvirt-daemon-system libvirt-dev libvirt-clients

E: Package 'libvirt-bin' has no installation candidate
thoreau@Thoreau:~/Installers/Whonix$ 

Otherwise, it was by the book.