[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Issues with Importing Whonix VM Templates in Jessie


#1

I’m currently attempting to get Whonix KVM working on my Debian Jesse set up. I’ve gone through all the steps laid out on the Whonix page, however when I run these following steps:

virsh -c qemu:///system define Whonix-Gateway*.xml
and
virsh -c qemu:///system define Whonix-Workstation*.xml

I’m confronted with this error message:

error: Failed to define domain from Whonix-(Gateway/Workstation)12.0.0.3.2.xml
error: internal error: no supported architecture for os type ‘hvm’

What am I missing? I have a feeling this is a noob problem with a simple solution, however it’s evading me.

Thank you very much in advance for any help at all!


Can't install Whonix in KVM
Internal error: no supported architecture for os type 'hvm'
#2

The error means the KVM kernel modules are not loaded on your system. This happens when Linux can’t use your hardware’s virtualization extensions because they are either unavailable or not enabled in the BIOS.

You will need to go into the BIOS and enable virtualization then KVM will work.

Not related to your problem, but I recommend using Whonix 10 with a Debian Jessie host when it comes out later this month because the configuration works best with it. Wheezy doesn’t support some features in the newer libvirt and it will give you a headache to get working.

check here:- Internal error: no supported architecture for os type 'hvm'


#3

I am able to use VirtualBox however; would this not mean that virtualization is active in my BIOS?

Thanks for the response and tip by the way, much appreciated. :slight_smile:


#4

I am able to use VirtualBox however; would this not mean that virtualization is active in my BIOS?

no, in Vbox things little bit different since Vbox using its own kernel. for 32-bit systems it doesnt require to have a virtualization in ur BIOS at all. more information about this check:-

even more here:-

https://www.virtualbox.org/manual/ch12.html

and i would like to add on @HulaHoop speech:-

  • if there is no virtualization option in ur BIOS u either can update ur BIOS to the latest release and check again, or contact ur computer company forum/mail asking them why its not available.if they didnt answer u then put the computer in the nearest trash or use Vbox instead (if u r not really paranoid about ur privacy/security)

  • another issue is: the BIOS is blocking the KVM ability even if there was the “virtualization” option and u have set it to “Enable”. in this case read here:-

http://www.linux-kvm.org/page/FAQ#.22KVM:_disabled_by_BIOS.22_error

  • last , even sometimes in some BIOSs there r crashes when enabling more than virtualizer like Hyper-v

for general detailed info read:-

http://www.linux-kvm.org/page/FAQ#

https://access.redhat.com/articles/1344173


for very short answer just enable the virtualization in ur BIOS (like the first comment) :slight_smile:

Thanks for the response and tip by the way, much appreciated. :smile:

uw anytime :blush:


#5

I checked out my BIOS, and unfortunately there is no options for virtualization so I believe a BIOS update is in order. Darn, nothing can ever be simple! *facepalm

Thanks a lot for your assistance, I’ll be sure to update on the situation as I progress. :slight_smile:

UPDATE: My computer unfortunately does NOT support virtualization :frowning: Time to start looking for a new one!