Anon-whonix qube proxy error... Tor disabled


Hello all,

I just installed Qubes 3.2, and I enabled Tor + Whonix Qubes at install time. Upon starting the anon-whonix qube and Tor Browser, a couple of strange things happen…

First, it always opens two tabs by default. The first tab is blank, the second tab is the Whonix home page (stored locally in /usr/share/ somewhere).

Second, when I try to visit any website like google.com or click on “IP check” in the Whonix home page, I get error that says:

The proxy server is refusing connections
Firefox is configured to use a proxy server that is refusing connections.
Check the proxy settings to make sure that they are correct.
Contact your network administrator to make sure the proxy server is working.

Since this is a brand new installation, I was confused and started poking around. In the Tor Browser I noticed it also says “Tor disabled” when hovering over the onion icon and there’s an X over it.

Are there some settings I need to setup in the sys-whonix qube first before accessing Tor?

When performing a whonixcheck in anon-whonix qube, the result message looks normal:

INFO: SocksPort Test Result: Connected to Tor. IP: xxx.xxx.xxx.xxx
INFO: TransPort Test Result: Connected to Tor. IP: xxx.xxx.xxx.xxx
INFO: Stream Isolation Test Result: Functional.
INFO: Whonix News Result:
√ Up to date: whonix-workstation-packages-dependencies 3.4.2-1
INFO: Debian Package Update Check Result: No updates found via apt-get.
INFO: Whonix APT Repository: Enabled. When the Whonix team releases JESSIE updates, they will be AUTOMATICALLY installed (when you run apt-get dist-upgrade) along with updated packages from the Debian team. Please read https://www.whonix.org/wiki/Trust to understand the risk. If you want to change this, use:
dom0 -> Start Menu -> Template: whonix-ws -> Whonix Repository

Any ideas why I’m unable to access Tor or websites within anon-whonix? Or why Tor is disabled?

Thank you for your help, and apologies if this should have been posted on the Qubes forum.

Access hidden services email server icedove through Qubes/Whonix
No longer able to access the net via my VpnVM?

Thanks for running whonixcheck. That rules out some possibilities.

What is your Tor Browser version?
(menu > help > About Tor Browser)

Please check your Network Connection Settings in Tor Browser:

Preferences > Advanced > Network > Settings

You’ve come to the right place!


Please also provide your anon-ws-disable-stacked-tor version. To find out:

dpkg-query --show anon-ws-disable-stacked-tor

Should be:

anon-ws-disable-stacked-tor 3:2.4-1


Thank you @entr0py and @Patrick for your assistance. Here’s what I have per your instructions:

Tor Browser
6.0.8 (based on Mozilla Firefox 45.6.0)
Tor Browser is up to date

The Tor Browser network setting is set (as per default, I haven’t changed anything):

Manual proxy configuration
HTTP Proxy: (blank) Port: 0
SSL Proxy: (blank) Port: 0
FTP Proxy: (blank) Port: 0
SOCKS Host: Port: 9150
SOCKS5 option is checked, Remote DNS is checked.

In Konsole, I ran your command and it returned:

user@host:~$ dpkg-query --show anon-ws-disable-stacked-tor
anon-ws-disable-stacked-tor 3:2.4-1

Does that tell you anything? Thanks for your help!


Only that it should be working. :confused:

I don’t have a means to test the installer so I can’t attempt to reproduce the issue. However, you are the first person to report this, here and on qubes-users.

Could you paste the results of
sudo systemctl status anon-ws-disable-stacked-tor
(should not be any personally identifying info)


If that above works, please also try the following debugging commands, that have just now been added here:



Well, well… looks like there’s no need. The issue seems to have resolved itself!

I noticed a pending update to the whonix-gw and whonix-ws template vms, and completed those updates. After restarting, Tor network is now accessible within anon-whonix. Strange.

I would not have originally posted if it wasn’t a persistent issue (through multiple restarts), as well as an issue which presented itself immediately after installation.

Thank you kind sirs for your time.