[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Workstation works but Gateway loads grub then just blackscreens with no error or other terminal output


#1

Host system is arch.

Setup libvirt according to the wiki (I don’t know if I did every thing right but if workstation works most of it must be right?)

I started and attached to workstation and it looked normal and as expected however doing the same with gateway it just shows the first grub screen and countdown then nothing. So it is very hard to know what is going on. No output on the host terminal either.

What could it be and/or how to ascertain the issue?

EDIT: I am able to get it running without using virsh with

qemu-system-x86_64 -boot order=d -drive file=Whonix-Gateway-14.0.0.7.4.qcow2,format=qcow2 -m 2048 -enable-kvm

However tons of errors for network related things (btw I did try with one other network switch which worked for an unrelated vm but didn’t work here and I thought removing all mention would default it as the arck wiki said it does default to system network) and no network connection however as a debug test this is instructive as in this case the machine actually loads and shows terminal output and ends up on the desktop. So any closer to seeing what might be the problem stymying the virsh version running?

I actually prefer running it just with the above command (simpler the better in my book) however I would not know where to start with making the gateway and workstation communicate with one another so don’t want to try steering too far off the tutorials’ path unless someone would hold my hand :).


#2

Can you please post the errors you see so I can get a clue on where to search? Also try updating your system sicne arch is a rolling distro and maybe whatever ugs you’re coming across may resolve themselves.


#3

I have been carrying on with virtualbox for the now but I will come back to this once I get some more free time.

There was no output on the gateway but there are on workstation startup so I will post the dmesg when I get a moment.


#4

I have the same problem with Whonix 14.0.0.7.4 with host Ubuntu 16.04. I allocated 256 MB RAM to Gateway because my computer has only 4 GB RAM but also tried with 512 MB and 1024 MB. Screen goes blank after “Loading initial ramdisk” message. I don’t want to use VirtualBox because I don’t trust it.


#5

You can try to use a more recent image with XFCE. Or maybe switch to a different tty with virt-manager and see whats going on, check the logs …


#6

no xfce images for KVM. 14.0.0.7.4 only KDE.


#7

I have xfce images already built ready for upload.


#8

Thats awesome news , alright please announce that once it finished uploading so i can share that through the social media.