[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Workstation unreliable DMA position…

hey, i recently noticed when i run the whonix workstation i got the following message three times
Error failed to sent host log messa
unreliable DMA position…
unreliable DMA position…
unreliable DMA position…
everything working fine, but i get these errors

See https://www.whonix.org/wiki/Reporting_Bugs#Support_Request_Policy

1 Like

That message comes up in journal boot logs. Usually not anything to worry about. Maybe this can help you: I have seen that same error several times over many different distros, not only Whonix. In my case, it was due to a pulseaudio error. Specifically, there was a discrepancy in the driver the virtualizer was using and the one that was on the operating system. To fix, I made sure the virtual sound device was ac97 and the host driver was correct. In my host case it was simple pulseaudio. Some use alsa or something else. Sometimes choosing intel_snd_hda as the virtual device can cause this error.
If that helps you, feel free to use those steps.

2 Likes

hello, thanks actually i tried to change my virtual sound from ac97 to soundblaster16, and the message stopped, do you have any idea why this worked, and did this affects my security ?

1 Like

Hi,
The choices (intel, ac97, soundblaster) are all “virtual” or emulated devices. They are there so that in case you have an os or a machine hardware device with a particular requirement, or maybe an external speaker setup, the apis and drivers can talk and are compatible.
I suggested ac97 because my particular setup of host and Whonix Workstation both use pulseaudio. ac97 works for that. Also, this is important, my physical sound device on the host (the real hardware as opposed to virtual devices) is the intel_snd_hda card. When I tried the virtual intel_snd choice, the sound was always choppy and sometimes the browser would freeze. ac97 did not. The error always appeared with the virtual intel, but stopped when the ac97 was used instead.
You can use whichever works the best for your setup. Of course make sure your host has sound enabled. In your case, probably your hardware agreed most with soundblaster.
Log Message:
Usually these are pci bus errors. The buffers used to send and receive audio information may not have been where the virtualizer thought they should be. Memory is accessed directly (the ‘D’ and ‘M’) and input and output flows between memory and device driver, real or virtual. The processor does not have a part in this exchange. (The ‘A’ is access) Pulseaudio has many workarounds for different hardwares; they call these “quirks.” Different cards are known to have different “quirks.”
Security:
If you are running a secure system, the risk is not huge. of course, anything that can access the memory directly or uses shared memory can potentially be a problem. If you just want to listen to something on your machine I wouldn’t worry too much. Where you go online to do this and what information they siphon would be a bigger issue.

2 Likes

Thanks, i found that intel hd audio works best for me, but i got a message again that i dont really understand
“snd_hda_intel corb reset timeout#1 corb = 0”
The problem i got with soundblaster is that there is no sound but no messages, sorry if my questions seems silly, but im totally new to linux, VM, and whonix

I’m glad intel hd sound is working for you; different controllers have different preferences.
Your question is not silly at all. We have all had similar questions at one time or another.
It is difficult to say what the exact issue is, but I’ll offer some insight based on my own forays in to the alsa and pulseaudio inner workings.
The “corb =0” errors usually have something to do with the codecs used with processing or reading the audio streams. If your sound is working properly (no choppiness, no interrupts, and no freezes) these messages are usually nothing to worry about. This message you are getting probably just means something is not where it was expected to be. So your journal will complain to let you know.

2 Likes
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]