[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Workstation screen resolution problems / workstation slowing down

Hi,

I just installed whonix in virtual box on a MacBook Pro. I used to use a Linux machine for whonix and everything was working fine, but now I have some issues running the workstation.

First of all, I don’t seem to be able to get the screen resolution right. The gateway works fine, big screen and high resolution, but any scale settings don’t work for the workstation in the same way, it keeps its low resolution. When I scale it, the window gets bigger, but the resolution stays low. When I try to resize the screen resolution for my virtual screen, it does not have any effect at all.

Also, the workstation does run, but it slows down quite often after a few minutes of browsing. Means, the tor browse reacts very slowly and any application I open takes ages to react. I did experiment a bit with the processors and general memory assigned to the workstation and tried higher or lower settings, but still no better result.

Below are the settings for workstation and gateway, am I missing the obvious ?
When giving advice…please keep in mind, I am a user, not a pro, so please keep it simple…thanks.

Any help appreciated :slight_smile:

Gateway:
System
Base memory: 2816 MB
Processors 2
Display:
Video memory: 128 MB
Scale: 1.25
Graphics controller: VMSVGA

Workstation:
Base memory: 4096 MB
Processors: 2
Video memory: 128 MB
scale factor 3
Graphics controller VMSVGA

https://www.whonix.org/wiki/Known_Issues#Screen_Resolution_Bug

…works like a dream, thank you !

Glad to hear! Welcome to Whonix forums!

As for the issue of Whonix-Workstation slowness, I don’t have a good answer for that. I could be something inside in Whonix or something on the host system. You could try to debug that. Running tools which show which applications start taking too much system resources (both in Whonix and on host).

sudo apt install iotop
sudo iotop -a

sudo apt install htop
sudo htop

Maybe “google” search term:

linux find resource hog
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]