Workstation no longer booting after disabling autologin - suddenly read-only filesystem - fsck

Hi, I’m not sure what I did, but I boot into Whonix today, did a system upgrade, disabled autologin, then browsed the internet for a bit before rebooting. Now, the VM won’t start. After GRUB, I get a tty prompt that says the following:

[FAILED] Failed to start systemd-fsck-root.service - Fi■on /dev/disk/by-uuid/26ada0c0-1165-4098-884d-aafd2220c2c6.
[DEPEND] Dependency failed for sysroot.mount - /sysroot.
[DEPEND] Dependency failed for - Initrd Root File System.
[DEPEND] Dependency failed for initrd-parse-etc.service - Mountpoints Configured in the Real Root.

Generating "/run/initramfs/rdsosreport.txt"

Entering emergency mode. Exit the shell to continue.
Type "journalctl" to view system logs.
You might want to save "/run/initramfs/rdsosreport.txt" to a USB stick or /boot
after mounting them and attach it to a bug report.

I followed the instructions on the wiki to Disable Autologin, but instead of restarting right away I did some more computing for a while until I noticed that certain files were suddenly read-only and I started getting prompts about being in a read-only file system when I tried to do certain file operations. Is this because I didn’t restart right away, or could it have been something in the upgrade? I don’t understand what happened. Gateway is fine, which I also upgraded today but did not disable autologin for

Ok, I don’t know why this happened, but I seem to have fixed it. After searching for an answer, I followed exactly what was written in this article:

Basically I ran systemctl status systemd-fsck-root, saw that it was /dev/sda3/ that was having problems, then ran fsck /dev/sda3 and answered yes to all. After powering off the machine and restarting it through Virtualbox, I seem to be able to log in again, but there was no login prompt like I originally wanted.

I probably am not going to mess with disabling autologin for now, I just hope I didn’t wreck anything else with my sudoedit. I only wanted a simple login prompt when I start the machine.

None of this is user mistake. None of this should risk file system corruption.

These issues can happen seemingly randomly with no fault by the user. Could be host hardware issues, virtualizer issues, kernel issues and whatnot.

Be extra careful with backups of any files inside the VM to avoid future data loss.

I recommend reading and applying the checks mentioned in chapter Hardware Issues.
(Whonix is based on Kicksecure.)

Also General VirtualBox Troubleshooting Steps might be helpful.