[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Workstation network connectivity down after recent update

This is a repost, but the original thread I tacked onto isn’t showing in the support category so not sure if anyone will see it. It is here:

I had another network problem on my gateway after the update, which
was resolved by editing /etc/network/interfaces
(whonixcheck fail: tor.pid does not exist after upgrade from Whonix 11 to Whonix 12)

Everything seemed to be working for a day or two after that. Then I’m
not sure if it was after a reset or when it happened but I have lost
network connection on my Workstation. Gateway still has a connection. I
did not touch Workstation networking.

Whonixcheck on Gateway comes back all good.
Whonixcheck on workstation “ERROR: Tor Boostrap Result: Tor’s Control
Port could not be reached!”

ifconfig looks correct on both as far as I can tell, but haven’t tried anything else besides rebooting.

Make sure /etc/network/interfaces looks like this.

# interfaces(5) file used by ifup(8) and ifdown(8)
# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

(The comments starting with # are actually not important. You can skip
them if you wish.)

Then make sure /etc/network/interfaces.d/30_non-qubes-whonix looks like this:
https://github.com/Whonix/whonix-ws-network-conf/blob/master/etc/network/interfaces.d/30_non-qubes-whonix

That was the same solution as my Gateway problem. I did not even think to look at that.
Worked like a charm.

Thanks for your quick responses Patrick!

Just now updated
https://www.whonix.org/wiki/Non-Qubes-Whonix_Known_bugs#No_Network_after_Upgrade_to_Whonix_12.
Thank you for the confirmation!

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]