[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Windows 7 as workstation won't work

Hello, I have been using whonix for a long time now, and it’s been great so far. This is the first time I try to use windows 7 as a workstation and I’m struggling to make it work, it just won’t connect to the gateway.
I followed all the instructions here: https://www.whonix.org/wiki/Other_Operating_Systems#Introduction_2

So i manually created a vm on virtualbox, running windows 7.

  • The gateway is up and running, updated.
  • I put the following settings in windows’ adapter:
    IP address 10.152.152.50
    Subnet netmask 255.255.192.0
    Default gateway 10.152.152.10
    Preferred DNS server 10.152.152.10
  • The computer name on windows is “host”
  • There are no other workstations running so there’s no IP conflict.

I tried to switch the network settings in virtual box from Nat to Internal network and viceversa, nothing seems to work, the machine just won’t get an IP.

Am I missing something? I really don’t know what to do anymore, thanks for your help :slight_smile:

Same internal network name?

Did you ever try if a non-torified Windows VM could even connect?

Is it a Windows driver issue?
(https://www.whonix.org/forum/index.php/topic,1592.0.html)

What do you mean by this?

Yes, I tried automatic settings without a torified environment and it works just fine.

[quote=“Patrick, post:2, topic:1388”]Is it a Windows driver issue?
(https://www.whonix.org/forum/index.php/topic,1592.0.html)[/quote]
It’s not a driver issue!

Network -> Adapter 1 -> Name (of Internal Network) (Important!): Whonix

[hr]

Did you use a)

If you want to manually create a VirtualBox VM (old, stable way), click on expand on the right.

or b)

If you want to download and import Whonix-Custom-Workstation template (experimental, testers-only), click on expand on the right.

?

I tried this exact settings for Win764bit and won’t work.

Is there any fix?

It must be some more settings to apply?

I also tried with Debian 64bit to make it a workstation, applied settings from whonix wiki. won’t work.

Only whonix workstation works. Other workstations dont. How to make them work, what setting to apply?
I need 64bit workstation.

It’s just a network connection - OS agnostic.

I just said I followed that exact tutorial and it won’t work. Same like OP.

Judging from posts, OP didn’t follow the tutorial exactly (missed VirtualBox VM settings).

If you are able to connect to the internet using Windows/Debian without Whonix, then no, you did not complete all the steps either. Make sure you click [Expand] when needed. You’re not the first person to connect a custom Workstation to a Whonix Gateway.

I believe that is not the case:

I tried to switch the network settings in virtual box from Nat to
Internal network and viceversa, nothing seems to work, the machine just
won’t get an IP.

I didn’t say I am able to connect, it wont connect at all with proposed settings.
I applied all settings on “Other Operating Systems” page.

If there is some other settings to apply, to make it work, I willl appreciate.

The first thing you need to establish is that networking is working in your Windows VM - forget about Tor / Whonix for now. Be careful here. Realize that as soon as Windows gets online, it will report back to Microsoft. If that’s ok, set your Windows VM Network Adapter to use NAT. (Or use Debian) Boot Windows and ping or visit a website.

If Windows networking is working, the rest is just a simple 2-step process: (again, this is all in the docs, maybe it’ll help to hear it explained my way)

  1. Gateway and whatever-Workstation need to be physically (or virtually) connected to each other - by a cord, wifi, or in this case by VirtualBox Internal Network, ‘Whonix’ (case-sensitive CAPITAL W).
  2. Once they’re located on the same network, you just need to setup a static IP in the workstation. For Debian, you would use NetworkManager GUI or /etc/network/interfaces. For Windows you need to edit Network Adapter properties.

That’s it. Try rebooting both machines. Still not working, did you make any changes to the Gateway or it’s VM Settings? Install firewall on workstation?

People aren’t rushing to help cause there’s not much more to say. This is how every workstation is connected to every gateway.

1 Like

Yesterday I made a progress with ubuntu workstation. I think it is working ok now, it is connected and tested in firefox shows tor IP (are you using tor page). Maybe I should run some more tests. One thing I noticed that tor was working pretty faster downloading, than when I use tor broswer in windows.

I will test your explanation and try again with windows workstation, and post results. Thanks

These are settings that I made in my linux kubuntu workstation,
so far it works, can you tell me is there anything wrong in this settings that
may „leak“ security?

I checked with regular firefox in this workstation (are you
using tor page). Is there anoher way to check is it secure connection?

I used your Whonix workstation also, I wonder why is there
also tor broswer in workstation? If gateway already give us torified connection?
Should I also install tor browser in my workstation, or I can use firefox
without tor?

Can’t see the images. If regular firefox in a workstation is showing you with a Tor Exit IP address, then your traffic is being routed through Whonix Gateway. You will not leak IP or DNS requests as long as your workstation has no other network connectivity besides the Gateway.

Not sure what you mean by “secure connection”.

All answered here:

1 Like

If I understand the reason to use tor browser in workstation connected to gateway is cookies?
Is there another reason?
If I set regular firefox in workstation to clear cookies on exit then it will be as if I use tor browser?

No.
Link must have been broken.

Just left-click on the blue text and you’ll have your answer. Not gonna rewrite what’s already written. I could copy/paste it for you but that would waste whonix.org bandwidth.

precious bandwidth. if you dont wanna answer just ignore. you dont have to answer as it was not addressed to you.

my question is not addressed to you so don’t answer with arrogant moronic BS.

It’s good to not duplicate stuff that is written in the wiki indeed. Duplication in the forums that is later forgotten and not updated when the wiki is updated pollutes the internet. Someone later would find this through search engines and get outdated information.

Anyhow. What’s being said on the https://www.whonix.org/wiki/Tor_Browser page at the top describes quite well what Tor Browser does which goes far beyond cookies. It also contains links to other websites so if that interests you, then it could keep you busy reading for days. Read that page from the top up to chapter “Tips”. And follow some links / footnotes. Should answer your question exhaustively.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]