WickrMe: snap install wickrme error: snap "wickrme" not found

Hello there !

I was trying to install wickrme on whonix for some time now

What i do :

sudo apt-get update
sudo apt install snapd
sudo snap install vlc
sudo apt update
sudo snap install wickrme

And what i get :frowning:
snap install “wickrme” not found"

Do people still manage to install wickr on whonix 16? Thank you in advance for your precious help

1 Like

Confirmed - but it should be available according to this:

This page also shows it installed on recent OS like Debian 11:

Might be a temporary website issue? You could always do an unsafe download here:

Followed by “snap install wickrme”.

(Unrecommended - you’d be better off raising this issue in the snapcraft.io forum: https://forum.snapcraft.io/)

Also note that Amazon has acquired wickrme. On that basis alone I wouldn’t trust it - far better alternatives are available - see the Chat section of the wiki.


I confirm that the possibility of installing wickr from snap seems to have disappeared. The error, like many “snap “wickrme” not found” and the advice from the wiki does not help.

There might be two issues here which combined are a huge usability mess:

  • WickrMe is responsible: The WickrMe developer might have decided to enable geographic IP blocking (blocking some countries and perhaps Tor, VPNs, etc.) or only allowing specific geographic areas (specific countries). Not allowed / blocked areas would be refused from snap.
  • snap is responsible: At the same time, snap in these cases does now show a proper error message in case of geographic IP blocking.


This is a similar case for a similar application which can be seen in snap web store but when attempting to download it will fail.

Exactly same instructions How-to: Use Wickr Me in Whonix ™ work when using a different IP. I am now certain that this is a IP geo blocking issue.

I’ve submitted a support request to wickrme. Ideally, they stop blocking the install over tor (which is what I think is happening). Their response will help me if a workaround is needed.

1 Like

Is there a way to download the package from that page? It takes me to Install wickrme on Linux | Snap Store and I don’t see a “manual download”.

1 Like

wickrme replied with:

Apologies, we do not block installing other than for certain locations: https://support.wickr.com/hc/en-us/articles/115007397508-Where-can-I-download-client-applications-

Wickr Software is subject to the export laws of the U.S. and other countries, which may affect your ability to download and/or install our software from our site or various app stores. See Wickr | Terms of Service for more information.

My exit node was Norway. I don’t think norway is on the list of US export restrictions. I responded and hopefully that elevate the issue and get a tech person in.

Meanwhile I’m working wiki instructions for manual snap install:

A big annoyance in the need to download from non-whonix and file transfer. I wish there were a (trustyworthy) mirror or something that could be done from within whonix. The snap webpage doesnt seem to allow direct downloads.

1 Like

Wickr can now be installed. A workaround has been added to documentation.

Hi @Patrick and all the community,

Would you (or anybody who wants) please support? I followed the Wiki but I am stucked.

Is there something wrong with snap? Should I reinstall it? Is it possible?

Thank you very much in advance.

Edit : I do believe I have an issue because I also have Snap Store installed.

I don’t know how to solve that, I definitely have a snap issue… Icons in Snap Store have disappeared.

Also posted here.

Did you use workaround

  • A) or
  • B)

as documented?

Yes. snap implements geographic restrictions / are blocking Tor users and at the same time don’t even implement a proper error message pointing that out instead show snap "wickrme" not found.

And what’s wrong with Wickr Me is that it is only available over snap store.

Thank you for your reply @Patrick

I used the A) documentation.

EDIT : correct it was B)

Enough for today I think…

From the screenshot I cannot see that workaround A) has been used. I suspected that it might have been done in Whonix, over Tor, which wouldn’t work. (Why? See documentation.)

I assume a non-Tor IP was attempted to download Wickr Me.

In that case, your geographic location could be censored by snap as ordered by Wickr. If that is the case, probably only workaround B) might work.

You are correct, tried to install it on Tor.

A lot of things have changed I see :face_with_raised_eyebrow:

I must read (again) the documentation as you propose.

I hope I’ll find out how the reinstall WickrMe or is it at this time not possible anymore?

So If I understand you correctly, Snap Store won’t work on Whonix anymore?

Again thanks for your help.

I have just had this post come through. I may be able to add something. I run Zorin (debian based) on another pc. For some reason wickr stopped working on that machine telling me that it needed to be updated but I couldn’t update it, there was no method. Anyway after research it turned out that this was a debian problem. The solution was to install, via terminal the ‘back channel’ version of wickr. This worked on a couple of my pcs. I don’t have the commands for this handy, and I have no idea if it will work on whonix, but it was a terminal installation that works fine for me.

Later on today I will find the commands and try it on whonix. It may or may not help and what I talk about could probably be searched for anyway.

1 Like

Would be kind of you Brad :+1:


Documentation already explains it as good as I can.

My goal is always to keep the wiki as helpful as possible. Users shouldn’t be required to read long forum threads to find out things.

Cumbersome yes, but possible as documented.


Only applications such as Wickr that instructed Snap Store to implement geographic restrictions / ban connections from the Tor network are affected.

Sorry, because of a lake of time I was hoping for a quick solution and didn’t read all the wiki.

Thanks for having answered.

Hi Brad
Would you please share your command lines on how you installed Wickr Me on Whonix?