[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Whonixcheck stuck at 45% in whonix gateway 13

Huston I have a problem…

Host: Debian 8.5 KDE
Guest : Whonix Gateway 13

Its been several hours I am trying to solve this but no success, tor circuit is not established suck at 45%. Clock is OK, whonixcheck debug command:

tor_consensus_status : verified
current_time_in_valid_range: true

current_time_torish : 2016-08-09 12:28:36
tor_consensus_valid_after : 2016-08-09 12:00:00
tor_consensus_valid_until : 2016-08-09 15:00:00
tor_consensus_middle_range : 2016-08-09 13:30:00

tor_cert_lifetime_output :
tor_cert_lifetime_valid : true
tor_cert_valid_after :

I also checked size of images with du -h Whonix-Gateway-*.qcow2
showing around 4.5G.

I also properly run command - sudo ln -s /etc/apparmor.d/libvirt/TEMPLATE.qemu /etc/apparmor.d/libvirt/TEMPLATE.kvm just as indicated in wiki.

TBB works on Host. I even went ahead, installed TBB in another VM and that also works.

What should I do ? Do I need to change anything in ‘.xml’ ?
Haven’t changed anything yet to avoid any conflicts.

It seems to be a whonixcheck problem/bug. I’ll move this to general support.

https://www.whonix.org/wiki/Troubleshooting#On_the_Gateway

I did everything as indicated on troubleshooting page and everything was as it was suppose to be but I noticed one thing with clock, even if the clock is in the range whonixcheck debug command still sometimes shows false, sometimes true.
I can confirm that my PC’s clock is OK.
Tried on debian xfce as kde was giving some random lag but still the same results.

Is your VM clock correct as per https://www.whonix.org/wiki/Troubleshooting#Clock_Fix?

Yes I did that too from the very beginning without any positive results

Whenever debug command shows clock as false I use clock fix (set command), it becomes true but bootstrap still never exceed 45%.

Did you change any settings such as timezone settings?

in WG? no. I didn’t change anything.

any updates? what should I do to make it work?

Were the network tests on Whonix-Gateway as user clearnet ( https://www.whonix.org/wiki/Troubleshooting#As_user_clearnet ) to connect to check.torproject.org functional?

This is the only thing I left because I dont want to reveal that I am a whonix user :slight_smile:

Can I use vpn to test this but I think that would cause another problem - clock sync.

I will still go ahead and try that out with VPN.

It’s an important test, otherwise we cannot pinpoint the error. I don’t
see how clock sync is related.

Install the VPN on the host. Installing it in the gateway would probably
make things more complicated.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]