whonix-xfce-installer-cli fails -- rsync .sig file does not exist on server

whonix-xfce-installer-cli: [NOTICE]: Downloading: ‘rsync://whonix.org/whonix/ova/’
whonix-xfce-installer-cli: [NOTICE]: Running: $ timeout --foreground 180 rsync-ssl --no-motd --progress --verbose --verbose --timeout 600 --max-size 2K rsync://whonix.org/whonix/ova/ /home/prospero/dist-installer-cli-download
opening connection using: /usr/bin/rsync-ssl --HELPER whonix.org rsync --server --daemon . (7 args)
verify depth is 4
sending daemon args: --server --sender -vve.LsfxCIvu --timeout=600 . whonix/ova/ (6 args)
rsync: [sender] link_stat “/ova/” (in whonix) failed: No such file or directory (2)

sent 8 bytes received 146 bytes 102.67 bytes/sec
total size is 0 speedup is 0.00
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1819) [Receiver=3.2.3]
rsync: [Receiver] write error: Broken pipe (32)
whonix-xfce-installer-cli: [ERROR]: Download: Failed to download files.
whonix-xfce-installer-cli: [ERROR]: Aborting installer.
whonix-xfce-installer-cli: [NOTICE]: Executed script, function, command: ‘/usr/bin/whonix-xfce-installer-cli’ ‘die’ ‘exit “${1}”’
whonix-xfce-installer-cli: [ERROR]: Exit code: ‘103’

Seems outdated whonix-xfce-installer-cl version.

Log lacks version number and command used.

1 Like

I ran the whonix-xfce-installer-cli command after an apt update/upgrade. Also tried using the “./whonix-xfce-installer-cli” script freshly downloaded. This works on my machine running Ubuntu 22, but not on my machine running Debian 11. It seems to be a problem with rsync-ssl?
I tried running:
$ whonix-xfce-installer-cli -V
and I get this:
whonix-xfce-installer-cli commit-hash-replace-me


Wrong file name.

Real file name is Whonix-Xfce-

Can be found here https://download.whonix.org/ova/

Now we getting closer. That’s why cutting the log wastes time.

Outdated Debian version. Therefore whonix-xfce-installer-cli also outdated. You need to upgrade to Debian 12 or at least download a newer downloader.


If you’re still using Kicksecure or Whonix bullseye (Debian 11) repository (derivative repository) then indeed, the installer (from package usability-misc) isn’t updated there.

Depending on what other packages you’re using from derivative repositories, changing APT sources list to bookworm (Debian 12) might not be a good idea without a full release upgrade to bookworm.

We didn’t have this case yet that someone on Debian 11 (oldstable) is using whonix-xfce-installer-cli from derivative repository. In that case, best to get the installer using curl. (Or git or any other method.)

1 Like

Thanks for that. I appreciate the time.