whonix WS kvm broken due to reinstalled security-misc

I just reinstalled security-misc.
Now, when I boot the VM desktop shows up, but the controls (mouse and keyboard) are not working.
Can someone help please ? :frowning:

before that I mask hideid, because I had problems mounting an external usb drive. But I managed to mount it now, it was an USB error… Now, to undo the hideid service mask, I just reinstalled security-misc

sudo systemctl mask proc-hidepid.service

sudo apt-get reinstall security-misc

I tried to boot in recovery mode now
STRG + D to continue

But then the same error:
keyboard and mouse not working anymore.

is smth broken due to the security-misc or masked proc-hidepid ? :frowning:

didnt test yet but you didnt take snapshot for your ws or gw before doing this change?

No I didnt take.
I just have an old snapshot of this machine :frowning:
Really need to fix it and hope someone can help

Steps to reproduce the behavior required.

  1. get a new Whonix VM
  2. run this command
  3. run that command

result is …

Just tested that now, i didnt get the same results (all good).

your on whonix 16 or 17?

1 Like