[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

whonix-ws 14/ where the tor?!


#1

I have updated whonix ws. In whonix-ws 14 there are no all that is connected with TOR what to do? back to 13?

if I updated to 14, do I now have to install test packets by default when the system is updated automatically or stable?


#2

Hi whonixbest

Did you also update whonix-gw-13 to whonix-gw-14 ? Tor will not connect if anon-whonix (based on Whonix 14) is connected to a sys-whonix (based on Whonix 13)


#3

yes, I updated whonix-gw and when I updated whonix-gw, then it was relatively long. and when I updated whonix-ws it was 5 times faster.


#4

Hi whonixbest

Nothing further needs to be done if you followed all instructions for Qubes-Whonix: https://whonix.org/wiki/Upgrading_Whonix_13_to_Whonix_14

Its always possible a mistake was made or something went wrong when upgrading. Did you receive any errors when you upgraded to Whonix 14?

Could you please run the following command in both sys-whonix and anon-whonix VMs

In konsole run.

whonixcheck

Please post output from both VMs


#5

Haha when I read the thread title I thought “where the Tor is the Tor?!”


#6

Are these the right commands? Am I doing the right thing? first update whonix-gw, turn it off. I turn on whonix-ws, update, turn off, then dom0!

Right?

whonix-gw

  1. sudo sed -i “s/jessie/stretch/g” /etc/apt/sources.list.d/qubes*.list
  2. sudo su
  3. export DEBDEBUG=1
  4. apt-get update
  5. apt-get install torsocks usability-misc
  6. apt-get-noninteractive dist-upgrade
  7. apt-get purge anon-shared-kde-accessibility kaccessible iceweasel firefox-esr exim* unattended-upgrades cups control-port-filter-python packagekit at wpasupplicant apparmor-profile-sdwdate apparmor-profile-whonixcheck kde-apper-no-autoupdate
  8. service whonix-legacy restart
  9. apt-get update
  10. apt-get install qubes-whonix-gateway
  11. sudo apt-get purge power-savings-disable-in-vms
  12. apt-get autoremove
  13. apt-get install --reinstall whonix-firewall
  14. systemctl unmask whonix-firewall
  15. systemctl enable whonix-firewall
  16. kdesudo whonix-repository-wizard
  17. sudo poweroff

whonix-ws

  1. sudo sed -i “s/jessie/stretch/g” /etc/apt/sources.list.d/qubes*.list
  2. sudo su
  3. export DEBDEBUG=1
  4. apt-get update
  5. apt-get install torsocks usability-misc
  6. apt-get-noninteractive dist-upgrade
  7. apt-get purge anon-shared-kde-accessibility kaccessible iceweasel firefox-esr exim* unattended-upgrades cups control-port-filter-python packagekit at wpasupplicant apparmor-profile-sdwdate apparmor-profile-whonixcheck kde-apper-no-autoupdate
  8. service whonix-legacy restart
  9. apt-get update
  10. apt-get install qubes-whonix-workstation
  11. apt-get install pulseaudio-qubes
  12. sudo apt-get purge power-savings-disable-in-vms
  13. apt-get autoremove
  14. whonix-repository-wizard
  15. kdesudo sudo poweroff

dom0

  1. sudo qubesctl state.sls qvm.anon-whonix
  2. sudo qubesctl state.sls qvm.updates-via-whonix

the end!!!


#7

HI whonixbest

Forgot these:

sudo whonix_repository --enable --codename stretch

sudo sed -i "s/jessie/stretch/g" /etc/apt/sources.list.d/debian.list

sudo rm -f /etc/X11/Xsession.d/50kde-apper-no-autoupdate